HELP Please Radeon X1950 Pro

Discussion in 'PC Hardware' started by rickrwg, Dec 1, 2009.

  1. rickrwg

    rickrwg MDL Novice

    Nov 29, 2009
    9
    0
    0
    Right here goes I have an ASRock AliveXfire eSATA2 R 3.0 with a Sapphire Radeon X1950 Pro. This is a Crossfire board so I got another X1950 Pro identical pair. With the first card I used the Sapphire provided power adapter as the psu one isn't long enough this adapter only has 3 wires 1 yellow 12V and 2 black GND. With the sencond card I used the psu power lead 6 wires 3 yellow 3 black I t all worked fine for a while I did the X3 rolling demo benchmark and saw a big improvement no problems. So I loads up FarCry and cranked the settings up to the max to see the performance I played for about 5 mins then the psu popped completly dead on the 12v side. Fairly old
    600W psu so i thought I'd just overloaded it. So I goes and buys a 700W good quality psu with 48 amps accross 2 12v rails loads of power to run this setup. I installed it with all the same power connections 3 wire on the original 6 wire on the new one all hunky dory until i fired up FarCry again and you guessed it the psu popped on the 12v side.

    So I guess my question is do these cards not like a 6 wire connector ive been scared to try my newest psu with this setup just incase it blows another 70 quid psu.

    I know I shoud get a newer card but I only play WOW and a couple of other DX9 games.

    Any help would be most appreciated and thank you in advance

    IM PULLING MY BLOODY HAIR OUT WITH THIS

    Cheers Rick
     
  2. OldMX

    OldMX MDL Senior Member

    Jul 30, 2009
    421
    141
    10
    Which brands of power supply? My CF loved my Corsair HX620, never had a single issue, it actualy powers my CF 4870.
     
  3. xman01

    xman01 MDL Novice

    Sep 9, 2009
    4
    1
    0
    i noticed you specified the brand of your motherboard and videocard, why not the psu?