Help with Acer Aspire 1640 battery support for Vista/7 (mod exists for other Acers)

Discussion in 'BIOS Mods' started by johnye_pt, Sep 25, 2013.

  1. johnye_pt

    johnye_pt MDL Addicted

    Aug 26, 2010
    592
    222
    30
    #1 johnye_pt, Sep 25, 2013
    Last edited: Sep 25, 2013
    I have an Acer Aspire 1680 with a modded BIOS where the battery was changed from "Smart Battery" to "Control Method Battery". This mod was made by Geert Jan Laanstra, and he posted it on his own webpage, along with practically all the instructions and tools. The purpose of his mod is to allow the battery to be seen by Windows Vista/7.

    I would like to do the same to an Acer Aspire 1640 BIOS, the problem is that I don't know jack about modding BIOS. I tried to follow his instructions, but when I got to step 4 where I need to modify ACPI0.ASL by comparing 2 ACPI0.ASL from another original and modded BIOS, I don't even know where to begin with. I tried emailing him a few days ago, but he hasn't replied. Maybe he doesn't check this e-mail anymore (page was last updated 4 years ago). He based his mod on a similar mod for a Toshiba L10 BIOS that I can't find anywhere, but his mods should be "easy" to follow for those with more expertise.

    There is also another step in case the BIOS doesn't correctly report the battery level, but that can be done later (it needs a HOLE2/3.ROM file from a similar laptop with the same platform/architecture and Vista/7 battery support, meaning I will have to do a scavenger hunt for service manuals...).

    Acer Aspire 1680, Travelmate 4000/4500 original and modded BIOS (ATI)
    Acer Aspire 1680, Travelmate 4000/4500 original and modded BIOS (Intel)
    Acer Travelmate 2300 original and modded BIOS (Intel)

    Acer Aspire 1640 original BIOS (Intel), this is the one I would like to mod.


    Please, please help me!

    EDIT: there is a 2nd BIOS for Acer Aspire 1640 with Vista support, it added "DVMT" to shared video memory options but not battery support...

    EDIT2: Ignore the 2nd BIOS, "DVMT" option was already there after all, it just removed the 64MB option, and I couldn't boot from my Kingston USB drive with it.