Help with activating vista on MSI GX620 laptop

Discussion in 'Windows Vista' started by jdc2009, Feb 17, 2009.

  1. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
    Please help me figure out and fix the problem I'm having with this GX620 laptop issue. I go and load vista on there like I did with my home computer and once everything is installed I load a vista activation crack like I normally would on the home pc, but once the laptop reboots it stays on the windows loading screen forever. When I run it in safe-mode it stops on crcdisk.sys
    I've tried various cracks on the web but all with the same result, why is it so much easier activating on my pc than it is for the laptop?
    Any help on getting this laptop to activate vista is greatly appreciated, just let me know what to do.

    Here are the laptop's info:
    Maker: MSI Micro-star Intl
    Model: GX-620

    Motherboard maker: MSI
    Model: MS-1651

    BIOS: American Megatrends Inc
    Version: A1651 IMS.10P
    Date: 12/26/2008
     
  2. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
    If theres no hope on getting it activating then could someone point me to where I can purchase a new vista ultimate x64 product key?
     
  3. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
    So I've been doing some research on working with this laptops bios, and while I dont possess any of the l337 modding or hacking skills, I can try to learn as I go.
    If the keywords "Activating vista on MSI GX620 laptop" is googled, it will bring up the web link for this thread, so hopefully this might help anyone else who purchased a gx620 laptop and is wanting help getting it activated.
    I've been installing vista x64 ultimate followed up by a crack app whenever I can get to the desktop. Once applied these cracks require a reboot to complete the process, but the problem I'm having is that once the vista loading screen comes up it'll stay there. I'll reboot and run "safe-mode", the drivers will load up until "crcdisk.sys". All crack apps I've used so far ends up with the same reboot problem.
    After reading around here for a while now I know the problem stems from the laptops BIOS. This MSI-AMI bios in particular is difficult to work with, since it apparently isnt as populer as Dell or Asus, there isn't that many crack apps that has whats necessary to activate vista. Something with the OEM key and SLIC.
    I've used Acronis True Image Home 2009 to image the partition where the os resides so I wont have to go through the whole process of installing vista then spending another hour setting up the drivers and configuring everything the way I like it. The image is just the basic install and driver install without any of the online updates.
    Right now I going to run WOW6 and see what happens, I'll be sure to post the results.

    **If anyone wants to help my predicament please post and give some tips or direction to get this problem resolved.**
     
  4. johnalvin

    johnalvin MDL Bios Modder

    Sep 3, 2007
    292
    21
    10
    #4 johnalvin, Feb 19, 2009
    Last edited by a moderator: May 23, 2017
  5. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
    laptop came pre-installed with vista x86 home premium.
    64-bit Windows Vista with SP1 x64 Edition MSDN DVD ISO is what I've used to install vista ultimate with.
     
  6. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
    I've put WOW6 on the laptop and followed the instrutions from Yen, rebooted and vista is now activated!
    Now I'm going to update everthing on vista online and see if vista stays active. I'll post the results.
     
  7. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    490
    180
    #7 911medic, Feb 19, 2009
    Last edited by a moderator: May 23, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
  9. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    490
    180
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    490
    180
    #11 911medic, Feb 19, 2009
    Last edited: Feb 19, 2009
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
    Vista has finished updating and completed reboot. Vista is still activated :D
    I'm keeping the files medic posted the links to on a external hdd along with any other tools and info I've come across that helped fix my problem.
    Thanks has to go to MyDigitalLife for having the knowledge and talented people to help fix this situation. :)
    Hopefully I wont have any other quirks with this laptop or OS once I deploy to Iraq later in March, but if something does I know this place will have the answer.
     
  12. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
    Yeah lets do it and thanks for the assist.
     
  13. jdc2009

    jdc2009 MDL Novice

    Feb 16, 2009
    10
    0
    0
    So let me get this straight, uninstall the WOW and apply the bios you fixed up? How would I go about uninstalling WOW and how does the certificates fit in the picture?
     
  14. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    56
    60
    You guys are both getting ahead of yourselves.

    If the laptop came with Vista on it then there is no need to run any cracks or BIOS mods, this is one of the confusing points about the cracks is that people assume they need a modded BIOS or a loader. If your laptop came with Vista on it chances are that there is already a SLIC in the BIOS, eliminating the need for a mod.

    What you need to do in the mean time before flashing the BIOS.

    1. Uninstall any loaders or cracks you may have installed. Like vistaloader or wow6 and reboot
    2. Run Everest and post the SLIC that is reported it should be MSI

    If the BIOS reports a valid SLIC then all you need is the MSI cert, and a Windows Vista key for what version you are using, Home Premium Ultimate or Business

    If the BIOS DOES NOT contain a SLIC then you need to flash it with a modded BIOS that does contain a SLIC or use a loader, then install the cert for the SLIC and a key for the SKU.
     
  15. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    490
    180
    I checked the bios...NO SLIC..This I did before the mod was posted..:p

    I did my homework!!:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    490
    180
    Instructions in the pack linked to in previous posts..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    56
    60
    Hmm wow interesting if it came preinstalled I wonder how it was activated...
     
  18. johnalvin

    johnalvin MDL Bios Modder

    Sep 3, 2007
    292
    21
    10
    #19 johnalvin, Feb 21, 2009
    Last edited: Feb 21, 2009
    wondering also here:confused: if it came pre-installed with vista my understanding is...it will be supplied with recovery disc or you have to make one by burning. with this you can reinstall the factory installed oem vista which does not require key and activation.
     
  19. armada

    armada MDL Addicted

    Dec 8, 2007
    857
    209
    30
    can someone tell me which slic i should be installing into vista? maybe a link to which one? do i use the asus one i didnt see a specific 620 msi version. that is all i need to get this working. or can i use any slic as long as the lic key matches im not sure. any help would be awesome. thank you in advance
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...