How do I stop UWP apps from preloading at startup?

Discussion in 'Windows 10' started by tfwmdl, Nov 10, 2017.

  1. tfwmdl

    tfwmdl MDL Novice

    Feb 18, 2010
    12
    2
    0
    Hi all,

    As the thread title suggests, how do I stop UWP apps from preloading at startup like SystemSettings.exe and Win.Store.exe? I've turned them off in the Background Apps, but they still load after the PC have been idle for 5 minutes even after manually terminating them through process hacker. It's just annoying having them load when I only use them once a week at most. I've looked through the registry but can't pinpoint where they are being launched from.

    Any ideas?

    Thanks.
     
  2. Demencial777

    Demencial777 MDL Junior Member

    Dec 30, 2012
    61
    10
    0
    As far as I have heard, seems SuperFetch service is the culprit for preloading this apps, I have the same issue, and after some readings, I discovered that. Seems disabling the SuperFetch service makes them not preload anymore... but you loose program and boot precaching and speedup... so, I just leave it as is...
     
  3. tfwmdl

    tfwmdl MDL Novice

    Feb 18, 2010
    12
    2
    0
    Disabled the Superfetch (SysMain) service but the Win.Store.exe App still preloads itself in the background, but on the upside SystemSettings.exe is not running after the PC is left idle for 5+ minutes. When gaming it's annoying having 6 or more processes launching in the background because Microsoft decides it's better to preload stuff :/
     
  4. frepsz

    frepsz MDL Junior Member

    Aug 26, 2014
    72
    18
    0
    You don't. You are the product. You do what Microsoft says.
     
  5. zen45

    zen45 MDL Senior Member

    Feb 25, 2010
    380
    489
    10
    with the last update windows 10 pro has 3 Cortana's prior windows had only 1 running in the background, it seems with each update there protecting there background start up programs and if you stop them from loading it seems to effect other programs where they don't run well or crashes on you !
     
  6. kaljukass

    kaljukass MDL Addicted

    Nov 26, 2012
    930
    315
    30
    Something is wrong with settings, they do not need to start automatically. Anyway, I have three computers here, none of them has ever had this problem and I never had seen something similar.
    Also, SuperFetch service is not prohibited, it is automatic and starts up always automatically.
    None of the program or other app will start unless I have asked for it. (Of course, I'm not talking about basic Windows services, at this moment running here 94 Windows services, but even all of them isn't mandatory.)
    So, You must find out, who has changed the settings on your computer so, that they start automatically.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. tfwmdl

    tfwmdl MDL Novice

    Feb 18, 2010
    12
    2
    0
    I found a way to stop UWP apps from being preloaded at idle. Open a Powershell command prompt and type the following...

    Code:
    Disable-MMAgent -ApplicationLaunchPrefetching
    Disable-MMAgent -ApplicationPreLaunch
    Also delete everything inside the PfAp key in the registry at...

    Code:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Superfetch\PfAp
    Boom, no more UWP apps loading when the PC is idle. I have just 69 processes if left alone after startup. :spoton:
     
  8. dhjohns

    dhjohns MDL Guru

    Sep 5, 2013
    3,276
    1,731
    120
    I had to put in Task Scheduler to have my Weather App, and Twitter App load at startup. How do you guys get all these UWP apps to load? I have never had them do that for me. I feel left out! :(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...