How do you modify Gigabyte Z77X-D3H UEFI Insyde BIOS?

Discussion in 'BIOS Mods' started by bhippy, Jun 21, 2012.

  1. bhippy

    bhippy MDL Novice

    Jun 21, 2012
    2
    1
    0
    #1 bhippy, Jun 21, 2012
    Last edited: Jun 21, 2012
    Please, Please, Please can someone provide me with a DETAILED step-by-step guide on how to modify/insert SLIC 2.1 on a Gigabyte Z77X-D3H UEFI Insyde BIOS with PhoenixTool.
    I am currently using the modified F8 (Structure+Dynamic custom) BIOS version from MDL as the F9 (Structure+Hex) version does not work for me. F9 boots but the BIOS menu hangs.
    I’ve been moding BIOS’ for years, so I know the basics and I know how to Hex edit but I can’t figure out how to mod this Gigabyte UEFI Insyde BIOS.
    This is what I have so far:
    1. Open PheonixTool 2.04
    2. Load original BIOS
    3. Set Manufacture to “other” for Gigabyte or Dell
    4. Load Gigabyte SLIC2.1 file or Dell.bin
    5. Load Gigabyte SLP file or Dell.txt
    6. Don’t load a RW file
    7. Verify Certificate successful for Gigabyte and Dell
    8. Set method to Dynamic
    9. Open Structure and replace DXE Driver {9F3A0016-AE55-4288-829D-D22FD344C347} with a compressed modified .MOD file. What this modified file is and how to mod it – I don’t know. I tried extracting the {9F3A…C347}.mod file from the F8 BIOS and use that to replace the F9 {9F3A…C347}.mod file, but that didn’t work. The BIOS menu again hangs.
    10. Open Advance options. I know something needs to be changed here, but I don’t know what.
    11. Save BIOS and flash in DOS using Efiflash.

    I know I can request a modified BIOS from MDL but I’d like to be able to mod my own BIOS.
    So if anyone can tell me what I’ve done wrong and what extra I need to do, then I’d be very grateful.
    Thanks in advance
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,354
    1,446
    180
    worked for F9 with Module in tool 2.0.2 with no SLP
     
  3. bhippy

    bhippy MDL Novice

    Jun 21, 2012
    2
    1
    0
    Thanks for your reply, and I think I've solved the problem with the BIOS menu freezing after flashing.
    As per your reply I modded the F10a beta BIOS with just a SLIC2.1 file and used Module method. I then DOS flashed the BIOS and rebooted. I then DOS flashed the BIOS again with the same BIOS file and rebooted again. I can now get into the BIOS menu and windows says genuine.
    I guess it's some kind of bug that the first flashing doesn’t quite stick so it needs doing again.
    Thanks again,