How to enable autorun/autoplay on Windows 7

Discussion in 'Windows 7' started by tuvi123, Nov 19, 2009.

  1. tuvi123

    tuvi123 MDL Addicted

    Jul 29, 2009
    629
    85
    30
    seems like the autoplay feature is somehow disabled on one of my machines..
    (I need to run autorun.exe manually from my game disks..
    also when I run a loader, I did not get the system partition autoplay screen)

    so how how do I enable it?

    thanks..
     
  2. vdl68

    vdl68 MDL Junior Member

    Sep 11, 2009
    77
    1
    0
    Go to the Autoplay control panel. it's under the Hardware and Sound,
     
  3. sam3971

    sam3971 MDL Guru

    Nov 14, 2008
    2,220
    303
    90
    #3 sam3971, Nov 19, 2009
    Last edited by a moderator: Apr 20, 2017
    You can also use the registry to fix that.

    chick start and type "regedit"
    Code:
    Navigate to HKLM\Software\Microsoft\Windows\CurrentVersion\Policies
    and delete any strings below "Default" and you should be good man! Had to do that many times myself so I know it will work.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. tuvi123

    tuvi123 MDL Addicted

    Jul 29, 2009
    629
    85
    30
    I have tried what you suggested
    but it still don't work for me...

    I have tried to insert my COD4 game disk and my windows 7 ultimate disk to the drive but it does not autorun/autoplay...

    I think 7Loader cause the autoplay issue.. it somehow disable it...
     
  5. sam3971

    sam3971 MDL Guru

    Nov 14, 2008
    2,220
    303
    90
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. tuvi123

    tuvi123 MDL Addicted

    Jul 29, 2009
    629
    85
    30
    #6 tuvi123, Nov 19, 2009
    Last edited: Nov 19, 2009
    (OP)
    my drive is ok...
    when I run AutoFix.exe it said "the program does nor tun on 64-bit windows"
    I have windows 7 ultimate x64 installed..

    now I get the system partition autoplay screen when I install Daz loader (when it mount the system hidden partition).

    but when I insert my DVD games (legal copies) / windows 7/xp disks - it does not automatically run the Autorun.exe from inside the disk drive..
    do you now how to enable the autorun?

    thanks.
     
  7. sam3971

    sam3971 MDL Guru

    Nov 14, 2008
    2,220
    303
    90
    Dude, I really do not know what else to think. What you can try doing is remove all the loaders, see if the problem is fixed. If so, install Daz loader, if the problem comes back, then you know it is the loader and you can ask Daz for advice. That is what I would do now dude. Let me know what happens k?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. tuvi123

    tuvi123 MDL Addicted

    Jul 29, 2009
    629
    85
    30
    OK, I fixed the problem :)
    I deleted the key ""NoDriveTypeAutoRun""
    in:
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

    it was in "HKEY_CURRENT_USER" and not in "HKEY_LOCAL_MACHINE".

    sam3971, thank you for your help..
     
  9. sam3971

    sam3971 MDL Guru

    Nov 14, 2008
    2,220
    303
    90
    #9 sam3971, Nov 19, 2009
    Last edited by a moderator: Apr 20, 2017
    oh, sorry about that. I never had problems with autoplay in win7 but I have on XP and it was
    Code:
    HKEY_LOCAL_MACHINE
    root. Anyway, I am glad to hear that you fixed it dude. Remeber that registry string so you can do it again if need be. It looks like vmware did that. I know vmware workstation 6 and 7 does that by default unless you turn off an option about host autoplay function.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. tuvi123

    tuvi123 MDL Addicted

    Jul 29, 2009
    629
    85
    30
    yes I have vmware installed.. so maybe you are right.. (it either vmware or 7loader or both, 7loader also disable the autoplay message..)
    anyway, thank you sam3971.

    so to anyone that has this problem:
    open regedit.exe:
    and remove "NoDriveTypeAutoRun" key from:
    1)
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policie s\Explorer

    2)
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policie s\Explorer
     
  11. sam3971

    sam3971 MDL Guru

    Nov 14, 2008
    2,220
    303
    90
    your welcome dude.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. Allard

    Allard MDL Novice

    Dec 28, 2009
    3
    0
    0
    Problem not solved

    Hello,
    When I read this solution I was happy. Still a change to solve this. But then when I search for "NoDriveTypeAutoRun" key from:
    1)
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\Policie s\Explorer
    or
    2)
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policie s\Explorer

    I have no results?:( Strange. Now I guess I have to re install Windows 7 and select Update so I can save all installed programs and settings. I hope that will solve the problem. Or has someone another (better) idea?

    Thanks in advance.

    Allard
     
  13. Allard

    Allard MDL Novice

    Dec 28, 2009
    3
    0
    0
    Thanks for your quick reply. In the control panel I have an auto play panel. I guess its the same as it should be as it's under the Hardware and Sound? And allmost all options are filled in. playing CD, DVD , play with Windows media player. empty CD, DVD , burn with Roxio.......But nothing works anymore.....:confused:

    Allard
     
  14. roirraW "edor" ehT

    roirraW "edor" ehT MDL Addicted

    Sep 1, 2007
    616
    213
    30
    Yep, definitely VMWare Workstation has been by default disabling AutoRun for years, as was mentioned. Just go into VMWare's options and find the right tab for that setting and uncheck the box to disable AutoRun. After this a reboot might be necessary for it to take affect.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Allard

    Allard MDL Novice

    Dec 28, 2009
    3
    0
    0
    Problem solved

    All settings were OK.
    I have used system recovery to set old settings back. Without succeed. Then with regedit I imported an old register back up. And that was the key to success :). I thank everybody for their help

    Kind regards

    Allard
     
  16. kewl1

    kewl1 MDL Novice

    Sep 18, 2010
    1
    0
    0
    FINALLY!!!! Thank you

    Hey I had the same problem driving me nuts for months and could not find a fix for Win 7 Ultmate 64. You fixed it!!!! Thanks man. :biggrin:
     
  17. cockatoos

    cockatoos MDL Novice

    Feb 9, 2010
    7
    3
    0
    go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    Locate the NoDriveTypeAutoRun registry entry on the right pane. The registry key is in DWORD hexadecimal value, which each bit determines which type of drive to disable or enable AutoPlay feature. There are many possible value for NoDriveTypeAutoRun, some possible wrong value that disable AutoPlay are:
    0x000000B5 (181) disable AutoRun on CD-ROM drives, plus default unknown drive, removable drive (meant for floppy or ZIP), network drive and reserved drive type.
    0x000000FF (255) disable AutoRun/AutoPlay on all drive types.
    The best bet is to set NoDriveTypeAutoRun to default value as set by Windows Vista, which is 0×00000091 (hexadecimal) or 145 (decimal). Previous Windows version such as XP uses 0×00000095 (hexadecimal) or 149 (decimal). To enable AutoPlay on all drive types, set NoDriveTypeAutoRun to 0 (zero) or 0×00000080 (128) which only disable AutoPlay on unknown reserved file type.
    Other possible NoDriveTypeAutoRun registry value data includes:

    •0×00000000 (0) enable all AutoPlay and AutoRun.
    •0×00000080 (128) disable AutoPlay on unknown reserved file type.
    •0×00000091 (145) default in Windows Vista and Windows 7.
     
  18. Jackie_Riley

    Jackie_Riley MDL Novice

    Jun 24, 2012
    2
    0
    0
    It didnt work.....

    I have tried everything that all of you have suggested and it still did not work.... When I went to HKEY_LOCAL_MACHINE/software/microsoft/windows/current version/policies/explorer It comes up with ForceActiveDesktopOn, NoActiveDesktop, and NoActiveDesktopChanges. Could one of those be my problem??
     
  19. im bored

    im bored MDL Member

    Aug 17, 2009
    166
    156
    10
    Start -> Control Panel -> AutoPlay -> Reset All Defaults (at the bottom of the page) -> Save

    Does that not work?
     
  20. Jackie_Riley

    Jackie_Riley MDL Novice

    Jun 24, 2012
    2
    0
    0

    Nope. That doesnt work either.