HOW TO REGRESS or DOWNGRADE to older INSYDE BIOS

Discussion in 'BIOS Mods' started by downloaddeviant, Dec 5, 2013.

  1. downloaddeviant

    downloaddeviant MDL Junior Member

    Jan 12, 2008
    64
    5
    0
    #1 downloaddeviant, Dec 5, 2013
    Last edited: Dec 11, 2013
    HOW TO REGRESS or DOWNGRADE to older INSYDE BIOS

    This is a simple step by step guide of a method to revert to an older version of InsydeH2O BIOS.

    Specifically this deals with a Toshiba Satellite C875D-S7105 laptop and INSYDEH2O BIOS but this method should work for similar circumstances and machines using the same BIOS but I make no promises. After discovering this method through hours of trial and error, I tried this process on some Toshiba Satellite display models at a major retail store. My friend works there and we did this after hours. It worked on every current Toshiba laptop that we tried.

    There is/are probably other easier ways to do this. I Googled, searched, read and posted requests for help and received none (yeah, even here). It might be as simple using Flas**t under DOS but I was afraid it would brick. I wanted to use a tried and true method. Here is what I did.


    The situation -
    My cousin accidentally upgraded his BIOS with the wrong BIOS for his laptop. A Toshiba laptop utility was recommending that the latest BIOS be downloaded and installed. What actually happened is that the software was wrong and would download and install the wrong BIOS, which would then, of course, make your machine act screwy! In this case, it downloaded BIOS made for mostly for the C855 series and a very select C875 model, but NOT for the C875D that he had!

    According to the forums, this utility was defective and many others suffered the same problem. From my research, it is clear to see two more problems. A - the Toshiba Support download section of their website is a freaking mess! B - Toshiba support and forum moderators were basically ignoring this issue. All I could see were forum users helping other users and a lot of angry customers. Myself included. I mean, how hard could it be for Toshiba techs to post a link to a simple bootable BIOS flashing tool to let you flash older firmware???!!!!

    Anyway, the utility downloaded and installed BIOS v6.30. Incorrect for this laptop. Worse, the correct firmware was v6.10. If you downloaded it and tried to flash it, it would fail and give you an error message about it being older than the current BIOS and would terminate the process. No option to manually override and flash it. Even their bootable CD would not allow flashing to older versions.

    STEP BY STEP HOW TO
    ***NOTE - your experience and results maybe very similar to mine or very different. I can only guide you with what I experienced first hand. Also, I figured this out through HOURS of trial and error. Below is the short version for you to follow along. You will be flashing under Windows, so be sure to have plenty of battery power, be plugged into the wall too and disabled all firewalls and anti-virus and security programs to prevent them from glitching the process.

    STEP #1 - Basically, I downloaded the correct BIOS EXE file then ran it. The file was skbqv610.exe. Upon execution it extracted to C:\skbqv610 and place a shortcut on the desktop.

    STEP #2 - Inside that folder is another self-extracting file called os2012381b_610.exe. You can simply decompress that manually. Inside that folder you will find another folder called UBIOS. For the sake of simplicity, I copied it to my desktop.

    STEP #3 - Inside the UBIOS folder were two folders - WIN7 & WIN8 - and two files - UBIOS.bat & WPID64.exe. I was working with Windows 8 64bit(yeah I know!!!!!) so I deleted the other folder and two files leaving me with just a WIN8 folder. If you are working with Windows 7, delete all but the WIN7 folder. These files must be deleted otherwise the result will end in an error.

    STEP #4 - Inside the WIN8 folder is a file called platform.ini. This is what you must edit. (***NOTE - it might work without editing this file, but at this point my .ini file was already edited so I cannot say. Feel to try it first. Nothing bad will happen. You will only get an error message or two.There is another file called ~platform.ini - you can ignore this or delete it.)

    From what I read at various websites, there are several sections that need to be changed. Basically, any section that says anything about comparing BIOS versions or platforms must be disabled.
    Example - section about 1/3 the way down says the following -
    [Bios_Version_Check]
    Flag=0
    CheckByBios=0
    CheckByBiosErrorMessage="This BIOS file is not allow to flash. The flash process will be terminated."
    ;This flag is the switch of checking BIOS version.
    ;Flag default : 2.
    ; 0 : Don't check rom file version.
    ; 1 : Check BIOS version.
    ; When rom file version is older then BIOS, it will display
    ; a warning message and close application.

    Where it says Flag=0 it originally said Flag=1. This means it was set to compare the versions and cancel out on you, ending the process without flashing. I saw a few other sections and I disabled them just to be safe. You can read through the .ini file for yourself below. Yours should be similar IF you have one. I noticed on some other INSYDEH2O BIOS files from Acer that there was no platform.ini set of instructions which might make it easier or impossible. I don't know.

    Here is my exact edited platform.ini file below





    STEP #5 - This is the easy part. Inside the WIN8 folder was the firmware (a file called C8610.FD) and the flashing program itself - InsydeFlashx64.exe. There is also InsydeFlash.exe (a 32bit version). Because I am using a 64bit OS, I simply ran InsydeFlashx64.exe. It executed and flashed the laptop back to the old correct BIOS version without any headaches or errors! I rebooted the laptop, hit F2 to check the BIOS version for myself then booted into Windows and tested the laptop. All the old problems were gone and everything was fine. Now, I am going to revert it back to Windows 7 because Windows 8 bites!

    I hope I have helped out or contributed to this site in some way. Please THANK and LIKE this post for me.

    Thanks!
     
  2. hbissou

    hbissou MDL Novice

    May 12, 2011
    6
    1
    0
    Very interesting thank you very much
     
  3. Underclocked

    Underclocked MDL Member

    Sep 3, 2013
    243
    41
    10
    I pulled a stupid stunt just yesterday. Working on cousin's computer - decided to update the bios (Toshiba Satellite P875-S7200). Went to Toshiba's support and downloaded the latest bios. Installed the bios. Holy chit!! Laptop about jumped off the table when I rebooted it... it did boot Windows but something was definitely wrong. Come to find out, Toshiba includes bios updates for a newer version in that list and makes no special note to warn complacent guys like me. Laptop hard drive making strange sounds, laptop running hotter, and weird things going on in the OS (like programs starting all by their lonesome). Quite a unique experience. :p

    So I went back to the Toshiba site and this time noticed the large jump in bios revision numbers. That alone should have clued me in... but it didn't. Downloaded two versions of the bios that were most definitely correct for the model sitting in front of me. Neither version would install due to the newer version already installed. Aaargh! After repeated attempts that failed and even an adventure into the bios files to see if I could bypass the version checker - no success.

    So I got this strange idea in the wee hours of this past morning to try something different. The bios upgrade package (Insyde) offers two ways to update. One is from within windows and the other from a bootable cd. Luckily, the Toshiba had a utility inside windows that allowed me access the boot order and change it (AND IT WORKED!!). I had been unable to access bios setup at all aside from that utility. Back to the bios file... this time I chose to make the bootable cd iso. I used Rufus to create a bootable usb stick from that bios installer iso.

    Against all odds, the version check was skipped and the older bios cleanly re-coded the bios. I once again booted to Windows and used that same Toshiba hardware config tool to reset the bios to defaults. On the reboot after the reset, all was well again in the cousin laptop world.

    The moral of this story is: I may be stupid but I keep trying. :D
     
  4. crazyodaz

    crazyodaz MDL Novice

    Feb 7, 2016
    22
    6
    0
    #4 crazyodaz, Aug 8, 2016
    Last edited: Aug 8, 2016
    Ya know what? -- I'm so freaking pissed, was it a cheap laptop? of course it was, but the cpu was supposed to have virtual garbage on it.......... so here i was, getting ready to update mine, to come on here and ask for a slic or modded or something, everything i found, even on toshiba site was the 610

    630 they started enabling the AMD-V on the pro sattelites but not the poor peoples version

    so thank you for this post, dont ask me how i stumbled on it, but talk about FREAKING HOT!!! yea dunno how long i've been running it like this, been fighting UEFI windows 7 installs with it, been overheating like who knows what, and to think at one time they had the gull to give me a FREAKING WIN10 UPDATE on this slow piece of garbage that had the AMD-V disabled

    anyways, thank ya for this, -- i will take a day or two to calm down, then come back really quick before i try your fix -- hey, atleast it wont run so hot right? -- and then i can hopefully get the modded one to enable some of this stuff --- yea-- never ever buying a toshiba again --

    thanks again

    ******* EDIT NOTE

    had to throw the temps up there, something told me long ago something was wrong, even spent all day tearing it apart, blowing some air in it cleaning out dust bunnies, and throwing in some artic silver from my desktop ---- i cant remember if i downloaded that bios or not, i must of, but it was also in the shop last year too, they had to verify the HD was gone in it -- i had Win7 running so good on it, the warrenty got me new HDD, but they plopped Win8 right back on there,

    wow, seriously... thank ya for this post, never once did i think i had the wrong bios running, it is all starting to make sence now, I've seen some wierd GUID paths, tables, and everything else with the laptop,

    crazy :(
     

    Attached Files:

  5. crazyodaz

    crazyodaz MDL Novice

    Feb 7, 2016
    22
    6
    0
    #5 crazyodaz, Aug 28, 2016
    Last edited by a moderator: Apr 20, 2017
    was going to just "EDIT" the above thread, but I figured I better not --- just wanted to say "THANK YOU" once again, though i did things a tad different. L875D-7332 is the piece of toshiba garbage I bought, one reason why i prefer desktops over laptops is the unlimited customization and addons, never did I think i would of bought a AMD with virtualization then that be disabled in the bios because it was not a "PRO" model , ya ask me manufactures should not allowed to do that, anyways I am over that now, lessoned learned and trust lost. NEVER will I buy another toshiba -- case closed.

    with that said, laptops aint cheap, so gotta make do with what I have, dont know when or how the 6.30 bios got put on there, but it did, and the dang thing ran HOT, after running into this thread I even did more and more research, somehow the bios is more for the UK than the US, Bios's aint nothing to be played around with, so i took a extra 2 weeks to back stuff up and research even more, this is what I did (tad bit different)

    =============================================

    1) followed all the rules above -- downloaded v2.66 of the phoenix tool here, above in the sticky section
    Code:
    
    
    
    2)so then I headed back over to the "OTHER" sticky thread here on MDL -- and using the phoenix tool above, got my own weird and wacky bios recovery name -- I Can't post Links or URL's yet, cause I am a NEWB wannabe -- but ya should be able to use the quotes given to link to the exact directions

    Code:
    
    
    
    3) IT'S GETTING SERIOUS NOW -- phoenix tool in one hand, instructions in the other, made sure that if I screw this up, I atleast got a way to recover, as much as I hate this toshiba-- cant afford another so i spent a hour or two comparing my "PLATFORM.INI" file with the instructions above
    Code:
    
    
    
    4) -- YA, I KNOW RIGHT? I mean talk about all this double checking and triple checking, making sure i got everything right -- there has got to be a easier way

    AND THERE WAS !!! INSIDE THE SKBQV610.EXE (7zip RAR extract like
    said at the very top of this thread, when I looked inside I noticed a "~platform.ini"

    so what i did, i renamed "platform.ini" to "platform.ini.bak" -- then renamed the "~platform.ini" to just "platform.ini" leaving out the squigly mark

    5) ONE MORE THING, incase you use the ~platform.ini like i did, look at the pictures below, one small section i did edit in there and that was to make a BACKUP before flashing, so it backed up the 6.30 that was in my computer and i still have them -- but my computer is running so much better now, thank you DownloadDeviant, seriously this AMD still runs sorta hot, but after a load she cools down so much faster now

    your thread here prolly bought my L875D-7332 a few extra years / PSKFQU-008003 / UPC: 022265278765 (all this so somebody else can search the answer)

    picture attachments of the bios.exe file breakdown -- extract to folder, then just run the UBIOS.BAT in root of the extracted exe, and a couple on the new bios tests, good little warm up then cooled back down fast, way faster than before, something with that 6.30 did not work right

    now if i can only get 7 to install in UEFI, thats another post for another day

    (AND NO -- DONT ASK ME HOW AMD-V IS WORKING ) -- seriously dont know if there was a setting in that ~ squigly ~ version or not, but you can see the 630 and 610 below, both runing aida in win10 -- it still slow, but there it is

    thanx again

    ***** I am only guessing, but I think the "~" version file is there for a reason, so phone tech support can easily tell somebody to do what i did but without so many words --- I COULD BE WRONG --- just sharing what worked for me, and i got some AMD-V out of it, --- use at your own risk if you decide, and back everything up,
     

    Attached Files:

  6. paul1149

    paul1149 MDL Novice

    Jan 2, 2012
    11
    0
    0
    Massive thanks for that, downloaddeviant. Once I found the bios version check section, it works perfectly. Also a Toshiba here, and man do they make it difficult!