HP DV7-1208ef - Bad Flash get ACPI Wrong [Solved]

Discussion in 'BIOS Mods' started by sankaris, Jun 15, 2011.

  1. sankaris

    sankaris MDL Novice

    Jul 28, 2010
    3
    0
    0
    #1 sankaris, Jun 15, 2011
    Last edited: Jun 17, 2011
    Hello !

    I've just flashed my HP DV7-1208ef bios with the one i've modded modded to include the SLIC2.1 (first it was a SLIC2.0) with WinFlash InsydeH20 original tool.
    Everything was OK until i can't boot in Windows 7 or Vista now (BSOD Stop:0x0000005, ACPI problem) or even reinstall from scratch

    I managed to reinstall Windows XP but with ACPI disabled and Standard PC HAL (F7 in installation) but can't flash with original bios under windows with WinFlash InsydeH20 [InsydeFlash can't load drivers]

    I also did this under DOS with flas**t but everytime i get a "Error: FADT not found !"

    I tested under Linux with Flashrom and it recognie the ICH9 but it complain about not finding the EEPROM/ Flash

    i also tried bios recovery (Winkey + B, Winkey + F, Winkey + ², Fn + B, Fn + F, Fn + Esc) with correct file on USB Drives (30F4.bin, 30F3.bin, 30F4.fd, etc...) but it seems that the laptop does nothing apart pass post Bios, not even a single activity on USB Drive or DVD.

    What can i do ? does anybody managed to recovery this exact model ?
    is there some way to force flas**t.exe to flash the bios ?
    can i use another utility ?
    Please help me.

    Best regards.
     
  2. drewbug

    drewbug MDL Member

    Aug 15, 2010
    232
    42
    10
    I think flashrom might be your best bet, unless you can get your hands on a replacement flash chip. What exactly is the error flashrom gives you?
     
  3. lordraiden

    lordraiden MDL Novice

    May 22, 2010
    3
    1
    0
    put newly named bin file on a fat16 or fat32 USB stick, plug it in the notebook
    -unplug notebook
    -remove battery
    -unit should be off, press and hold windows key and B
    -plug in AC power while holding those buttons
    -turn on notebook, let go of all buttons once LED lights come on
    -the notebook will beep every second, as it searches for the .bin file
    -if its filename matches your systems motherboard code, it will flash, and reboot
    -all is fixed

    this work for me and a dv7-1020es this is the same bios.
    my system board id is 30F4 and i rename 30F4F2D0.FD to 30F4.bin
     
  4. sankaris

    sankaris MDL Novice

    Jul 28, 2010
    3
    0
    0
    This is what flashrom gave me:

    I did that many time, but doesn't seem to work.. :/
    - i formated 2 different USB Stick (1Go each) with Fat23 and even Fat16 (even tested with a DVD-R)
    - i renamed 30F4F2D1.FD (seems to be that one for my board in platform.ini) to 30F4.bin (remark: the tool that modify the bios told me to rename the recovery bios file to F4.bin, but that didn't work either)
    - The Laptop boot, start to beep with the Winkey+B (beep repeatedly and sound like a key stuck in the keyboard) but does nothing (the usb key didn't event flash) until 5 ou 10 sec and then boot normally (HP Bios Logo and all).
    - I'll test again tonight with another USB stick.
    Thanks for the advices :)
     
  5. lordraiden

    lordraiden MDL Novice

    May 22, 2010
    3
    1
    0
    I use a 512mb flash drive.
    try the others files.
    rename 30F3F2D.FD to 30F3.BIN (DIFERENT SYSTEM BOARD ID)
    rename 30F4F2D0.FD to 30F4.BIN
    copy to flash drive an try.

    I modified the bios with PhoenixTool 1.8 and now works correctly. The problem must be a bug in PhoenixTool 1.85
     
  6. sankaris

    sankaris MDL Novice

    Jul 28, 2010
    3
    0
    0
    #6 sankaris, Jun 17, 2011
    Last edited: Jun 17, 2011
    (OP)
    Hi again,

    I tried today with another USB Key and the crisis recovery bios thing worked like a charm !
    -> FAT32 - Full Format (not Quick) / Extract 30F4F2D1.FD and renamed 30F4.bin then put it on the USB Key
    -> Removed battery / plug in AC power while holding those buttons
    -> Turned on notebook, and then let go of all buttons once LED lights come on

    Maybe that was the bold part i missed last time i tried it... i waited in fact till the screen showed up a blinkin cursor for letin go WinKey + B
    Thanks a Lot LordRaiden :)

    Now i'll try to find PhoenixTool 1.8 and start the mod again. (I used PhoenixTool 1.85, maybe that's why it din't worked for me)

    Edit: Done the 2.1 SLIC mod with PhoenixTool 1.8 and worked perfectly with it!
    PhoenixTool 1.85 must have something wrong with the SLP field modding

    Thanks everyone, problem solved !
     
  7. ibby_1994

    ibby_1994 MDL Novice

    Apr 13, 2012
    1
    0
    0
    hello
    i have a dv7 3101sa, i wz updating my bios driver, but i turned it off thinking it has crashed , and now when i turn it on i gt a black screen. its a few weeks out of warantty so no point of asking hp.
    i also delete the partition which had the recovery on it( i didnt know what it was at the time :I).

    i hav download my bios update and extracted my 3635F13.FD file. i have renamed it to 3635.bin and copied it to a usb floppy, but when i plug it in and press the winB keys, my laptop beeps once or twice but then restarts and nothing happens.

    any help would be appreciated as i hav only had it for 6 months, and i dont want to pay another 400£.

    thx