HP dv9904ca dead after "recommended" HP BIOS upgrade

Discussion in 'BIOS Mods' started by SteBo06, May 11, 2012.

  1. SteBo06

    SteBo06 MDL Novice

    May 11, 2012
    I have a HP dvd9904ca laptop, which worked just fine. Then I decided to upgrade the BIOS (to F34) as per HP's "recommendation" (thanks very much HP!).

    The flash process (within Windows) succeeded and the machine shut down afterwards. When I powered it back on, nothing happened. No access to the HDD, nothing. Not even the BIOS screen.
    I then started surfing the web trying to find a solution and fix.
    What I've done so far:
    I got myself a USB floppy drive and 3.5" floppy, downloaded and ran "crisdisk", coped the extracted WPH file(s) on the disk and tried a recovery.
    The laptop boots from the USB disk (after holding the Windows + B keys, then pressing the power button, releasing both keys a few seconds later). Everything seems to go as planned, lots of beeping, the machine shuts down but after turning it back on, still nothing.

    Here is a question I just couldn't find an answer for yet: when I extract the BIOS file, I see two WPH files (an "A" and a "B"). As both files won't fit on the floppy, I tried first "A", then"B". But no luck.
    Is there a single BIOS file somewhere for my machine I can use?

    FYI, the laptop is out of warranty and contacting HP is senseless as I have been transferred around and finally gave up.

    Any lead would be much appreciated as I really would like to use this machine again.

    Thanks in advance!