HP Elitebook 8440p Bios Update Failed please i need help

Discussion in 'BIOS Mods' started by soneto, May 15, 2013.

  1. soneto

    soneto MDL Novice

    May 14, 2013
    4
    0
    0
    i tried to update my bios and failed..
    now it tells me "me FW update failed pls try again"
    i tried to do a bios recoveovery by holding windows key and B botton .
    the leds flashed for about 10 seconds then it restarted and displayed that it has updated succesfully and also displayed code 500 success.
    now if i start my system it displays the same message,"me FW update failed pls try again" but powers off abruptly 15-20 mins leta..
    tried hp assistant but was told to replace the the board and i know this is not tru...
    plzz i am a new user and an amerture as a stsp by step guide would be helpful...
    thanks..
    have also downloaded and updated the most corrent bios out for it "F23" which didnt work
     
  2. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,274
    1,166
    90
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. soneto

    soneto MDL Novice

    May 14, 2013
    4
    0
    0
    Ive tried holding down win key and b key wile powering on the system. in got the recovery page which eventually updated but while restarting it it brot up the same message saying "ME Fw Failed please try again"

    am preety sure itz not hardware problem. please i need help anybody
    thanks...