HP-media-card-readers no longer get "Safely Remove Hardware" announcements.

Discussion in 'Windows 10' started by TeppoT, Jan 22, 2019.

  1. TeppoT

    TeppoT MDL Novice

    Nov 28, 2013
    5
    0
    0
    I just resently noticed that my HP_Media/Multi_Card_ Reader will no longer get "Safely Remove Hardware" announcements. I´m using Desktop PC. I think this behaviour started from Win10 build 1803 onwards.
    I´m using win10 build 1809 and there the phenomen is clear.

    Seems that MS has made new rules how to handle HP-media-card-readers (at least in Desktop PC´s).
    Can anybody confirm this?


    At HP website you can learn that:
    "Memory card readers are devices that use the Safely Remove Hardware icon in the notification area on the taskbar). Do not click Stop in the Safely Remove Hardware window. Doing so can disconnect the memory card reader from Windows. If this happens, restart the computer to reinitialize the memory card reader.".
    "When you have finished working with the files on a memory card, right-click the memory card icon and select Eject". These guidances are for Win XP and Vista.
    *****//support.hp.com/my-en/document/bph07910
    Sorry I can not post real link due so low total posts, but add "HTTPS:" to above insted *´s
     
  2. MELERIX

    MELERIX MDL Addicted

    Nov 7, 2011
    993
    467
    30
    I guess is normal, because in some card readers when you use eject, it also eject the whole card reader and it will not read any card again until you restart PC xD
     
  3. TeppoT

    TeppoT MDL Novice

    Nov 28, 2013
    5
    0
    0
    Well, I remember that I have allways (many years that is) "Safely Removed My Hardware" whit this card reader what I´m talkin about. Untill now, when Windows has changed that removal policy, and I think that it happened in build 1803.
    That is my case, and I was seeking someone else confirm also the conclusion.
     
  4. DLord

    DLord MDL Novice

    Aug 17, 2012
    22
    3
    0
    This happened to me for all USB devices when my notifications broke down after update to 1809.
    But never had any such problem on 1803.
     
  5. TeppoT

    TeppoT MDL Novice

    Nov 28, 2013
    5
    0
    0