HP Pavilion PV7 BIOS fault

Discussion in 'BIOS Mods' started by Cyclistbruce, Jan 26, 2014.

Tags:
  1. Cyclistbruce

    Cyclistbruce MDL Novice

    Jan 26, 2014
    2
    0
    0
    Hi,

    I have an HP Pavilion DV7-3027-ea. It developed a fault in the BIOS, I think related to the ACPI. I was able to install and run Ubuntu, but I now need to reinstall Windows. I get a blue screen of death during installation and the recommendation is that I upgrade the BIOS.

    I created a bootable USB with flas**t.exe installed and the BIOS upgrade file from HP: 3635f13.fd

    When I attempt to flash it I get the following fault:

    Insyde Flash Utility for InsydeH20 version 1.2j

    Current BIOS model name: 3639
    New Bios Model Name Raven/Lassie 2.1

    Current Bios Version: F.08
    New BIOS Version: F.13

    Protection: the ROM file is not match this platform.
    Error: the new image file is not support flash utility

    I've tried renaming the file and changing the extension to .rom and .bin, but get the same fault each time. Has anyone got any ideas?
     
  2. tonto11

    tonto11 MDL Addicted

    Jun 18, 2012
    592
    260
    30
    #2 tonto11, Jan 26, 2014
    Last edited: Jan 26, 2014
    First are you sure the bsod is not caused by a corrupt Win installation disk

    Second I would not touch the bios unless the new one had a new function that I could not live without.

    That having been said I would expect the new bios
    model name to be very similar to the old one, not vastly different like you show.

    When I google HP: 3635f13.fd I get a bunch of threads which talk about DV6 not DV7

    I think your "protection " is trying to save you from a worse problem
    a bricked computer.

    ...T
     
  3. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,356
    1,446
    180
  4. Cyclistbruce

    Cyclistbruce MDL Novice

    Jan 26, 2014
    2
    0
    0
    Sorry, my typo; its a Pavilion DV7-3021EA. I got the BIOS update from the HP website, it comes as an excecutable and I extracted the .fd file from it.

    I've tried a couple of Win installation disks (Win 7 and XP) and get the same ACPI.sys error. I was told that it was most likely a BIOS fault, but am willing to look at alternative ideas!!