HP system won't boot after BIOS Flash

Discussion in 'PC Hardware' started by jbrame, Jul 29, 2008.

  1. jbrame

    jbrame MDL Novice

    Jul 29, 2008
    1
    0
    0
    I have an HP Pavillion A1720N that I tried to update the BIOS with sp37378. During the update process(a windows bios flash), the system froze. I waited for several hours just to make sure it would comeback but not. I recycled the power and now I get

    Award BootBlock BIOS v1.0
    Copyright (c) , Award Software, Inc.

    BIOS ROM checksum error

    SP37378 is supposed to flash the BIOS to version 5.23. The system was at version 5.21 before I started.

    I have created a DOS boot CD and have tried several version of awdflash.exe with rom file 523.rom as well as 521.rom but I get error message “Unknown Flash Type”

    The system is 13 months old so just out of warranty. Called HP support and after a $50 Support call they want to sell me a new MOBO for $315.00 or a new system.

    Seems to me there should be a way to reflash the BIOS rom.

    The MOBO is a ASUS P5LP-LE (Leonite) with Award BIOS

    any help would be greatly appreciated
     
  2. reginakampher

    reginakampher MDL Addicted

    Apr 5, 2008
    678
    149
    30
    #2 reginakampher, Jul 29, 2008
    Last edited by a moderator: May 23, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...