I have AMD-V Support, but BIOS Update Removed it does it still support Virtualization

Discussion in 'Virtualization' started by coast123, Dec 29, 2013.

  1. coast123

    coast123 MDL Novice

    Dec 26, 2011
    25
    0
    0
    I have a Toshiba Satellite C655D-S5302, with AMD-V support or was anyway. I had updated my bios to Insyde Version 1.80 which had removed the option for the AMD-V. I just noticed this and I want to install Mac OS X Mountain Lion VMware image from the souldevteam website. It said "VMware cannot access this Machine because your computer does not support this option, or is disabled. I checked in my bios and It was there before the update. Strangely it disappeared in the latest update. Is there an way to modify or downgrade at all to a previous version that I had it, I really would like to know. Also I am I the only one who has this problem If not that's okay, but if anyone found a fix for this or there is a safe way to have this option back on the bios please let me know. I tried to reinstall VMware but it still could not find it, I have looked at other ways such as bios mods but I am new to the whole bios options. Please Let me know if there's a workaround or hack for this I am running VMware Workstation 10 but not sure what version. However I am a registered developer for Apple and Microsoft and would like to get this working again so I can test my apps and software again.

    Any help is greatly appreciated. Thanks Also Have a Happy New-year.
     
  2. user_hidden

    user_hidden MDL Expert

    Dec 18, 2007
    1,026
    973
    60
    did you go into bios after flash and press "Load Setup Default" or something similar.
    then reboot and check if the feature is now available in the bios?
     
  3. coast123

    coast123 MDL Novice

    Dec 26, 2011
    25
    0
    0
    I tried that it still is not there:mad:
     
  4. MrG

    MrG MDL Addicted

    May 31, 2010
    811
    180
    30
    I suppose if you backed-up your old BIOS while flashing the new one you could reflash w/ the old one.
     
  5. Snowderblazer

    Snowderblazer MDL Novice

    Feb 18, 2014
    1
    0
    0
    it supports VT / Virtualization technology but does not mention if it supports
    vt-x or vt-d or both

    here is some info
    [h=3]AMD[/h] Segmentation support is missing from the initial AMD64 processors (that is, revision C and earlier) while running in long mode. As a result, AMD64 processors prior to revision D do not have an efficient mechanism for isolating the virtual machine monitor from 64-bit guest operating systems. A limited form of segmentation was reintroduced in long mode, in revision D AMD64 processors. As a result, AMD64 processors must be revision D or later to run 64-bit guest operating systems.
    Note: Because AMD Opteron and Turion processors do not ship in revision D, AMD Opteron and Turion 64 processors must be revision E or later to run 64-bit guest operating systems.
    When reading AMD's documentation, revisions may be given in decimal format (rather than hexadecimal format). For example, Revision F may also be referred to as Revision 15.

    Processor Check for 64-Bit CompatibilityProcessor Check for 64-Bit Compatibility
     
  6. PGHammer

    PGHammer MDL Senior Member

    Oct 14, 2011
    361
    73
    10
    Do you have an original Turion x64 or the later Turion II (which is actually closer to the Phenom II/Athlon II).

    I have two HP notebooks with AMD CPUs - the one with the Turion x64 does NOT support Hyper-V, but the Turion II-powered version does (in fact, it has Server 2016 10074 on it for use as a mobile developer platform).

    The difference is (of course) AMD-V (the AMD version of SLAT).

    The quirkier part is that Windows Server 2016 10074 installed fine - Hyper-V and all; however, Windows 10 Pro or Enterprise later than this same build will NOT run with Hyper-V enabled in the BIOS - all attempts to install it as a feature in those builds fail or lead to black-screen failure/instant reboot heck.