Is there a way to prevent Bitlocker password prompt when switching GPUs

Discussion in 'Windows 10' started by Ultra Male, May 8, 2017.

  1. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,127
    503
    60
    I have a laptop with both the Intel and nVIDIA GPUs. If I enable Bitlocker and reboot after a GPU switch which is done by a button on the side, Bitlocker prompts me for my password again since it thinks now I have new hardware. This is getting tiring, can I have it not prompt me for a new password upon detection of a hardware change?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. dmex

    dmex MDL Junior Member

    Apr 20, 2011
    92
    103
    0
    You can 'suspend' bitlocker and it doesn't ask for a password for the next boot?

    Powershell:
    Suspend-BitLocker C:
    Suspend-BitLocker C: 10 (suspend for next 10 reboots)

    Cmd:
    manage-bde -protectors -disable C:

    Or you could go buy a Yubikey Neo or Yubikey 4 (standard), configure the device with a 'static' password and press the button on the key to make it type the password for you :)
     
  3. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,127
    503
    60
    Thanks a lot man
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,531
    519
    120
    Another thing is to enable Bitlocker not to ask for password on the system from both GPUs(in Intel and in Nvidia).
     
  5. ZoltanS

    ZoltanS MDL Novice

    May 12, 2017
    1
    1
    0
    So how do you enable the BitLocker not to ask for password from the GPU's?
     
  6. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,531
    519
    120
    I mean when you switch to both GPUs make sure you tick the box in 'automatically unlock on this PC' under 'More Option' . Whenever you are now switching GPU it will recognize it.