Issue installing Linux Mint on Acer Aspire 8930G.. Need help

Discussion in 'Linux' started by Hugefiang, Dec 28, 2018.

  1. Hugefiang

    Hugefiang MDL Novice

    Aug 17, 2018
    6
    2
    0
  2. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    683
    970
    30
    Hello @Hugefiang - First question: Did you verify the .iso you downloaded using the SHA256 checksum before you burned it to DVD? For Linux Mint 19.1, they are as follows:
    b580052c4652ac8f1cbcd9057a0395642a722707d17e1a77844ff7fb4db36b70 *linuxmint-19.1-cinnamon-32bit.iso
    bb4b3ad584f2fec1d91ad60fe57ad4044e5c0934a5e3d229da129c9513862eb0 *linuxmint-19.1-cinnamon-64bit.iso
    ca86885e2384373f8fbb2121e2abb6298674e37fc206d3f23661ab5f1f523aba *linuxmint-19.1-mate-32bit.iso
    5bc212d73800007c7c3605f03c9d5988ad99f1be9fc91024049ea4b638c33bb4 *linuxmint-19.1-mate-64bit.iso
    039d619935c2993e589705e49068a6fa4dc4f9a5eb82470bc7998c9626259416 *linuxmint-19.1-xfce-32bit.iso
    7b53b29a34cfef4ddfe24dac27ee321c289dc2ed8b0c1361666bbee0f6ffa9f4 *linuxmint-19.1-xfce-64bit.iso

    If you already verified the .iso and burned it correctly, then it sounds like a video driver issue. It's common with both Nvidia and AMD graphics cards that aren't happy with the open source video drivers and need the proprietary drivers installed instead. I'll outline what you have to do, just be aware that it's a two step process:

    1.) Pre-installation - This involves getting your graphics to work temporarily so that you can proceed with the installation from DVD.
    a.) Boot the machine using your installation media.
    b.) During the 10 second count-down, press any key, like the space bar. This will bring up the boot options menu. Select "Start in Compatibility Mode". Doing this will boot the machine using generic VESA video drivers instead of the open source video drivers.
    c.) Proceed to install Linux Mint, then reboot the system when prompted to do so at the end of the installation.

    2.) Post-installation - This involves getting installed system to boot so you can install the proprietary Nvidia drivers.
    a.) During the reboot, as soon as your BIOS splash screen disappears, hold down the left side Shift key. This will bring up the Grub boot menu.
    b.) Now press the "e" key to edit the boot parameters.
    c.) Use your up/down and left/right arrow keys to scroll down to the line that starts with "linux". Scroll over to where you see "quiet splash". Now remove "quiet splash" and substitute "nomodeset" in it's place. DO NOT change anything else!
    d.) Now press Ctrl + x to save the changes and boot. Now you're running in Software Rendering Mode using the generic VESA drivers.
    e.) After you get to the Desktop, go to System Settings, and locate Driver Manager. Open it, and you should see an option to install your proprietary video drivers. Install the drivers, then reboot the machine.
    f.) Once again, hold down the left side Shift key, then press "e" to edit the boot parameters, and change "nomodeset" back to "quiet splash". Again, press Ctrl + x to save the changes and proceed to boot.
    g.) If everything went OK, you should now be running the proprietary Nvidia drivers in place of the open source drivers.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Hugefiang

    Hugefiang MDL Novice

    Aug 17, 2018
    6
    2
    0
    #4 Hugefiang, Dec 29, 2018
    Last edited: Dec 29, 2018
    (OP)
    I will try it, and do i need to select (Install 3rd part software like for Video cards, MP3, etc) or just leave that unticked?

    EDIT: i will try it tonight, because my friends just picked me up, i will shoot you a message if it has worked correctly orn't :)
     
  4. Hugefiang

    Hugefiang MDL Novice

    Aug 17, 2018
    6
    2
    0
    #5 Hugefiang, Dec 29, 2018
    Last edited: Dec 29, 2018
    (OP)
    OMG, it works! Thanks :D
     
  5. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,870
    3,964
    180

    As the OPs problem was solved, any idea why the last 2-3 releases of Ubuntu refuse to install on my HP Presario (About 10 years old, DualCore /2GB RAM), it gets to the timezone options and tells me it failed to set a timezone, if I proceed anyway it fails, if I try again the timezone error continues, this happens wireless/Wired, connected or disconnected from the net

    Last one that worked was I think 17.04

    Tried multiple USB sticks, ISOs etc
     
  6. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    683
    970
    30
    #7 John Sutherland, Dec 29, 2018
    Last edited: Dec 30, 2018
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    683
    970
    30
    Hello @MrMagic - Thanks for posting the screenshots, the first error message might be a good clue. When I get a chance later today I'll look into it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...