Lenovo Flex 10 BIOS Update Issue

Discussion in 'BIOS Mods' started by titomno2, Sep 10, 2014.

  1. titomno2

    titomno2 MDL Novice

    May 29, 2014
    6
    0
    0
    Hello Everyone,

    I have an issue with lenovo support.
    I have updated properly my OS from windows 8 32bit to windows 8.1 32bit, it work fine except since the update waking up from sleep freezes the pc.
    This issue is fixed with a new bios for the 64bit version (which is a shame for the poor 32bit users we are).
    I contact several times Lenovo support, they did not answer.

    here are the link for the actual 32 bit bios.
    download.lenovo.com/consumer/mobiles/93cn19ww.exe
    BIOS name£º93CN19WW
    Support models: Flex 10
    Support OS: Windows 8 (32-bit)
    Version: V5.2
    Problem fix:
    Fixed auto enter S3 under stand mode.
    Limitation (if any):N/A
    How to install the BIOS:
    Run the downloaded 93cn19ww.exe directly.

    And here the new version:
    download.lenovo.com/consumer/mobiles/93cn52ww.exe
    BIOS name£º93CN52WW
    Support models: Flex 10
    Support OS: Windows 8.1 (64-bit)
    Version: V9.2
    Problem fix:
    1. Fixed it will hang up or reboot after S3 resume.
    2. Add board ID to detect V1.7 board for USB port change.
    Limitation (if any): N/A
    How to install the BIOS:
    Run the downloaded 93cn52ww.exe .

    So if anyone can help me i will really appreciate.

    One more thing apparently all actual Insyde tool for backing up the actual BIOS seems to not working.

    Thank you for your attention and please accept my appologies for my bad english.
     
  2. Marconi

    Marconi MDL Novice

    May 28, 2011
    1
    0
    0
    I also have one of these Flex 10 machines - with an N3510 quad core 64-bit processor.
    Sadly the Lenovo EFI BIOS is 32-bit only, so cannot install any 64-bit OS.

    After upgrade to Win 8.1 32-bit, cannot resume from sleep - having to use hibernate instead.

    Would prefer to upgrade to the 64-bit BIOS and install a 64-bit OS
    But of course the above 64-bit exe won't run on the existing 32-bit OS !

    Have extracted the contents of each of the above exe files.
    Looks like a solution might be to switch the 64-bit binary file into the 32-bit installer.
    Reluctant to do that as it might result in an unworkable machine.
    Wondering if anyone else has tried this, or any other workaround, and had any success?

    All Flex 10 machines sold more recently have 64 bit EFI and 64 bit Windows.
    Crazy that Lenovo has left early adopters with no way forward for their 32-bit only EFI setup.
    MS say we should upgrade from 8 to 8.1, but if we do that then our machines no longer work properly.
    Thank you Lenovo !!
     
  3. titomno2

    titomno2 MDL Novice

    May 29, 2014
    6
    0
    0
    Hello Marconi,

    I have now a german version N3530 + 4GB + WIN 8.1 64Bits.
    Lenovo support tells me that the motherboard of several version are not compatible with 8.1 !!!
    Traduction
    Thank you for contacting support.
    The processor 3510 is not supported by motherboard compatible with windows 8.1 64bits.
    Only models compatible with windows 8.1 64bits are the one equiped with native windows 8.1 64bit pre installed and following processors:
    N2806, N2815, N2920, N3520...

    It's a shame, they do nothing to help people except saying it's impossible to change the bios with a version correcting the default.

    Concerning puting the 64bit fd file with the 32bit installer, the bios update begin, the system detect that the new version correctly then restart to apply this upadate and display a big Update Failed, you're still with the 32 bit version.

    Once more lenovo did not directly the support for ideapad, it's medion !
     
  4. robb_www

    robb_www MDL Novice

    Oct 13, 2014
    1
    0
    0
    This matches my experience. I have attempted to install the 64bit BIOS by placing it inside the 32bit BIOS installer but this failed (fortunately without damaging the system).

    Could one of you please clarify how much memory Windows 8 (32bit) is reporting as available to you with the N3510 version of the Flex 10 ? I am having difficulties with my RAM and am unsure if this is normal with the Flex 10.

    If you open explorer, right click on Computer and choose Properties, or equivalently if you go to "Control Panel\System and Security\System", does it say "Installed memory (RAM): 4GB (1.84GB usable)" or do you get a different number?
     
  5. titomno2

    titomno2 MDL Novice

    May 29, 2014
    6
    0
    0
    I don't have the N3510 version but the N2805 and 2GB, i have also 1.84GB usable because of the shared memory for the graphical part.
    This is normal.