LENOVO (IBM) Bioses, especially Thinkpad.

Discussion in 'BIOS Mod Requests. Post Requests Only' started by ancestor(v), Jun 17, 2009.

  1. stinghamster

    stinghamster MDL Novice

    Sep 30, 2013
    2
    2
    0
    The link is dead, does anyone still have this file?
     
  2. Serg008

    Serg008 MDL BIOS/EFI Guru

    Feb 23, 2010
    21,226
    9,388
    390
  3. RussianT530

    RussianT530 MDL Novice

    Mar 21, 2013
    41
    22
    0
    T/W 530 and 430 can only be done with hardware programmer - the embedded controller blocks writes to BIOS from OS and runs upgrades from its own upgrade code that verifies digital signature - see my previous posts. You can reuse the module from T530 to disable WL on your W530 (which in fact is not that much different from T530), but you'll have to use external hardware programmer and unless you figure out how to use manufacturer SPI connections or to disable SPI traffic on the board while programming, you'll have to desolder the BIOS chip to program it.

    I've successfullyt done three x530 boards using the method I have described earlier.
     
  4. bugs.bunny

    bugs.bunny MDL Novice

    Oct 2, 2013
    4
    2
    0
    Works fine, thank you very much! :)

    Another question please: if I update this ThinkPad Edge E531 to a new BIOS version (1.17 for example), does the marker work, too? Or should I request for a new mod?

    bugs.bunny
     
  5. thanh2h

    thanh2h MDL BIOS/EFI Modifier

    Aug 23, 2011
    3,176
    2,765
    120
    This's permanent slic.
     
  6. ion_ta

    ion_ta MDL Novice

    Oct 6, 2013
    2
    0
    0
    Hello, I'm trying to change the DMI strings on a lenovo x200 tablet, and the manufacture won't update still says Lenovo when I query the WMI even though in Phoenix WinPlash shows updated manufacture name written on in the chip. Does Lenovo not let us change manufacture or what is the problem ?
    Other X series work fine
     
  7. ion_ta

    ion_ta MDL Novice

    Oct 6, 2013
    2
    0
    0
    Further testing... it seems that I cannot use a 2 word string in the manufacturer field, how can this be bypassed ? it works on other IBM laptops just fine with 2 words in the motherboard manufacture field
     
  8. kblake71

    kblake71 MDL Novice

    Oct 8, 2013
    8
    0
    0
    Would you be able to provide the SLIC bios for a z60t. We tried the one for the z61m and it did not work. Thanks in advance.