:mad: Newer driver keep comming back!

Discussion in 'Windows 10' started by spkleader, Aug 12, 2015.

  1. spkleader

    spkleader MDL Senior Member

    Oct 13, 2009
    262
    63
    10
    Hello MDL!

    I'm having a blast with some profilic drivers on Windows 10.
    It's a simple USB to COM interface... but profilic didn't added support for it in the newest drivers (which I belive that come with Windows 10) so it installs with an exclamation mark.
    BUT, I found out that if use an old old old driver version from 2008 that was signed by MS, it works without problem... till I disconect and reconect it.. then windows installs the newer driver again!

    There's anyway to FIX this issue? It's driving me mad!

    Thanks in advance.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. arifkarim

    arifkarim MDL Member

    Feb 17, 2011
    124
    66
    10
    Use windows update hide tool or use portable update. Both should fix your problem. ;)
     
  3. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,539
    4,989
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. spkleader

    spkleader MDL Senior Member

    Oct 13, 2009
    262
    63
    10
    Thanks for the answers guys!
    But the problem isn't with windows update. In fact, I just checked in anothercomputer, windows 10 doesn't have drivers for it.
    I've installed the new driver manually (there's no installer), then tried to uninstall using the option in the device manager (even told to erase the drivers) but they keep comming back even after installing the old version.
    I tried to erase them from he drivercache folder as well and boom, they're comming back like a plague! :D

    Options?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. endbase

    endbase MDL Guru

    Aug 12, 2012
    3,901
    1,197
    120
    Look if the driver sit's here C:\Windows\System32\DriverStore\FileRepository
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. spkleader

    spkleader MDL Senior Member

    Oct 13, 2009
    262
    63
    10
    Welp, I did a mix :D
    and it seens to have fixed it.

    Reinstalled the driver using the "use disk provided by manufacturer", it installed the old drivers, then did what arifkarim told me to do. The new driver didn't came back :)

    Thanks for all the help guys!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. arifkarim

    arifkarim MDL Member

    Feb 17, 2011
    124
    66
    10
    Glad I could help! :biggrin: