MSI / Acer MS-7510 BIOS recovery

Discussion in 'BIOS Mods' started by ÜñdeaD, Mar 17, 2011.

  1. ÜñdeaD

    ÜñdeaD MDL Novice

    Mar 16, 2011
    4
    0
    0
    #1 ÜñdeaD, Mar 17, 2011
    Last edited: Mar 17, 2011
    Hello, I have a MSI board that was OEM for Acer, P7N Diamond / MS-7510.

    I downloaded the newest BIOS from MSI and attempted to flash, the flash seemed to have worked, but now the system will not post on barebones. It was posting fine before the flash so I think this screwed it up.

    After looking I saw Acer had some different BIOS for the same board, R01-A1 was the original version.
    I stupidly flashed with MSI's 7510v14.

    I have been trying the recovery methods I have found, but this board only has an IDE port and I have no floppy on hand to see if it would work in the port. (It's been years since I've installed a floppy, but I'm pretty sure it's a different port.)
    So I read that the USB method should work, however I get no indication the USB is being read when I boot.
    Holding R-CTL+HOME.

    The system is not giving any beeps when I power it on either. EDIT: However the fan on the video card is coming on and the lights on the MOBO as well. There is no onboard video so I am using a PCI-E card that was working fine before the flash. Any suggestions or ideas are very welcome!

    Thank you in advance!

    EDIT : I have also found this board is used in the Acer Aspire G7700 if this helps. I really just need to find out how to get into recovery mode on this.
     
  2. ÜñdeaD

    ÜñdeaD MDL Novice

    Mar 16, 2011
    4
    0
    0
    I have been looking everywhere.
    I know people have made modified BIOS for this board, which means someone would know the recovery method.

    After all my searching, I still cannot find the way to recover this. I have a usb floppy, and ps2 keyboard. There is no floppy connection so it has to be over USB.

    It's just so frustrating. >.<
     
  3. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,487
    633
    60
    If you power it on does the usb fdd turn on/get seeked?
    If so maybe you can have the rom on floppy & it will auto flash.
    Go to the msi www site & have a look at there recovery procedure. You probably have to rename the file to ami.rom or something...
    Does the bios even fit a floppy? Maybe the flash is from usb key.
     
  4. ÜñdeaD

    ÜñdeaD MDL Novice

    Mar 16, 2011
    4
    0
    0
    #4 ÜñdeaD, Mar 18, 2011
    Last edited: Mar 18, 2011
    (OP)

    The USB does not seem to be powering on at all, LED on the usb floppy doesn't turn on, neither does the USB stick.
    I also have a CD-Rom I just connected and this does seem to spin up when the power is started. I burnt the proper BIOS to a CD and renamed to AMIBOOT.ROM as I have found in instructions, but it spins at first, then doesn't continue seeking.

    Also, the whole reason I'm in this mess is I grabbed the BIOS from MSI, since this is OEM I should have used Acer's.

    It does seem like the CD-rom is seeking, however I have found a few OEM AMI BIOS look for different filenames, e.g. ;SUPER.ROM for supermicro AMI BIOS.
    I am wondering if it's looking for a different filename.
     
  5. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    489
    180
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. vivek.krishnan

    vivek.krishnan MDL Novice

    Dec 13, 2009
    48
    7
    0
    How about creating a bootable DOS cd with an autoexec.bat file so that it will start the bios flashing procedure on boot?
     
  7. ÜñdeaD

    ÜñdeaD MDL Novice

    Mar 16, 2011
    4
    0
    0
    #7 ÜñdeaD, Mar 18, 2011
    Last edited: Mar 18, 2011
    (OP)

    Will this work on AMI? I thought it used boot block to recover. How would I go about doing this?

    The server is not giving any post beeps, meaning that autoexec.bat wouldn't run. :(
     
  8. thelaibon

    thelaibon MDL Novice

    Apr 24, 2011
    1
    0
    0
    Undead -- have you found a solution to the problem? I have the SAME EXACT motherboard, and did the SAME EXACT thing you did -- I put in the P7N Diamond BIOS v14, when I should have stuck with the Acer BIOS, as this is an Acer product, even tho manufactured by MSI. However, before putting in the P7N BIOS v14 via DOS, I had tried the Acer BIOS flash and it wouldn't take. Seemed that it was simply not the right BIOS, so I pursued the MSI BIOS. Like you, I have no post, no video, no options, no BIOS. I start the PC and the HDDs power on, CD Roms, etc. but that's it. I also do not have a floppy.

    Were you able to find anything?
    If you'd rather respond via email, my address is djcoryminto at gmail dot com