MSI z87I Bios booting issue (After v1.4 alwasy boots to bios)

Discussion in 'BIOS Mods' started by propered, Jun 22, 2016.

  1. propered

    propered MDL Novice

    Feb 10, 2010
    27
    3
    0
    #1 propered, Jun 22, 2016
    Last edited: Jun 22, 2016
    Always boots to bios after bios update have to downgrade to 1.4 for normal function

    Bios available
    https://www.msi.com/Motherboard/support/Z87I.html
    v1.4 ---------> 1.5, 1.6, 1.7, (1.8 unavailable) 1.9
    http://download.msi.com/bos_exe/7851v19.zip
    http://download.msi.com/bos_exe/7851v17.zip
    http://download.msi.com/bos_exe/7851v16.zip
    http://download.msi.com/bos_exe/7851v15.zip
    http://download.msi.com/bos_exe/7851v14.zip

    Win10 Pro
    UEFI
    GPT
    SSD (only drive)

    ever since upgrading my bios from v1.4 for this motherboard the OS always boots to bios first
    I have
    tried MBR and GPT
    Disabled/enabled Win8/fast boot etc
    changed order of boot etc
    reinstalled several times
    used default settings
    cleared cmos
    tried different ram, cpu, ssd
    changed settings in bios, unfortunately the issue seems to be with the bios

    I have to downgrade to v1.4 for this to continue working normally (ie boot to os first not bios)

    I am not sure what changed between booting v1.4 ---------> 1.5, 1.6, 1.7, (1.8 unavailable) 1.9
    but only 1.4 works fine and i'd like to upgrade my bios as haswell refresh support was added
    of course I would prefer latest bios but was wondering if anyone can help and see an obvious change beween 1.4 and all other newer bioses that have this annoyance. No worries either but if its an obvious fix cool but if not,l 1.4 it is :) no worries
     
  2. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,475
    627
    60
    Have you checked the boot order? Windows boot manager should be first.
     
  3. propered

    propered MDL Novice

    Feb 10, 2010
    27
    3
    0
    Hi

    Many thanks for your reply, yes i did check this, and made sure it was first in all areas of the bios it was possible to change it 1st in boot order. No luck
    But as soon as i revert to v1.4 it boots normaly again (to OS and not to bios screen)
     
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,264
    1,422
    180
    if im correct.. you have memory sd card reader on usb like printer or internal to pc and CSM Legacy enabled.
    basically its switching device priority and looking for boot method and fail so goes to bios.
    try setting hdd only and remove from boot devices others and set efi only not combo csm legacy and efi.

    im speaking from limited time i played with sons crappy msi pc mate type... i got me a gigabyte Z97-HD3 v2.3 and loving it just like my old G31M-ES2L v1.1
     
  5. propered

    propered MDL Novice

    Feb 10, 2010
    27
    3
    0
    Many thanks for your input, i think i did try that but I'll try that today and let you know how it goes...luckily i can downgrade easily enough to 1.4
     
  6. propered

    propered MDL Novice

    Feb 10, 2010
    27
    3
    0
    Hi

    just an update to say I tried all that, and 1.9 just wouldnt boot into os...always went into bios, regardless of changing the boot order to WBM, and then removed all other boot options too etc.
    i suppose it's an error of the board but not sure why it works perfectly fine in 1.4

    Many Thanks for your input guys

    (suppose i could ask would it be easy to update microcodes on 1.4? )