Multi-OEM/Retail Project {MRP} - Mk3

Discussion in 'MDL Projects and Applications' started by mxman2k, Oct 15, 2016.

  1. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    #2441 mxman2k, Mar 23, 2018
    Last edited: Mar 23, 2018
    (OP)
    if you are using your custom theme as it is then it wont work, some files are missing that are required for the theme to work.

    If you look at the oem's.7z 'custom' brand folder in the new MRP you will see what files it requires.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. DMDraegon

    DMDraegon MDL Novice

    Apr 8, 2015
    17
    6
    0
    Yes it is in the OEM's.7z
    I also left one (Acer) untouched as recommended to leave one, the others are stripped.

    I hope so, here is the content of my file which I also stripped:
    :Version=2.5

    :AutoDriveRename=Yes

    :CustomTheme=MG

    :END

    Stripped or unstripped the problem remains.


    Edit:
    @mxman2k it worked before fine?
     
  3. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    :CustomTheme=Custom

    MRP does not look for anything other than the brands listed in the GUI. Change the ini to the above line.

    Also make sure all files are present as the MRP will tell you that some files are missing. The reason all the files are required in the brand folder is so that the theme is correctly set for all os's otherwise it may have elements missing.

    You can remove the acer folder too, as long as you just have the CUSTOM brand which i am guessing is the one you wish to use?

    Let me look again at your 'custom' folder and see what files are missing...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. DMDraegon

    DMDraegon MDL Novice

    Apr 8, 2015
    17
    6
    0
    I get it now, I've not looked in the "Custom" folder.

    Could you change the text in page one?
    It stills mentions:
    "• You can force install 'ANY' brand theme by reading and using the Force_Theme_[readme].txt"
    and
    "If you do edit the OEM's.7z file please make sure when you re-compress it that the file structure/layout is exactly as it was, or the project may use the Windows default theme as a fail-safe procedure. You can delete any brand folders not required to make the archive smaller, but you MUST have at least ONE of the brand folders within OEM's.7z."

    This is confusing.
    I didn't think of looking through ALL brand files to find "Custom" existed, which also isn't mentioned in your Important Read Me

    I think I will manage now, I report back.
     
  5. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    user810.bmp, user.bmp, Custom_bar.bmp, custom_badge.png, custom_badge.bmp,custom.theme are missing hence why it wouldn't work with the new MRP.

    I can create them if you wish and upload a Custom folder that should work?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    I have to go through all the readme files as yes there have been changes and will get that sorted asap.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. DMDraegon

    DMDraegon MDL Novice

    Apr 8, 2015
    17
    6
    0
    See my previous post, I think I will manage now. I got most files you mention but in my own folder.
     
  8. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    rename your folder to Custom, add the missing files required and you should be good to go :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    #2449 mxman2k, Mar 23, 2018
    Last edited: Mar 23, 2018
    (OP)
    Updated first post about the force_theme mistake :oops:

    Also the part about OEM's.7z structure regarding the one 'brand' folder or just Custom one.

    I hope that the new wording makes sense.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. DMDraegon

    DMDraegon MDL Novice

    Apr 8, 2015
    17
    6
    0
    Hmm, now the Project.log file says that he found the theme but it still isn't applied after install.
    I copied over my files to CUSTOM keeping exact file name as original custom file names.

    Log file:
    Multi-OEM/Retail Project Version : 180322-R86.0 - BaseLine [MRP via MDL Forum ONLY]

    Required project files extracted successfully.

    OEM's folder detected, structure appears OK.

    MRPconfig.ini file:
    :Version=2.5

    :AutoDriveRename=Yes

    :CustomTheme=CUSTOM

    :END
     
  11. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    Just updated the Important-ReadMe.txt file about the Custom Theme layout requirements.

    =========================
    Notes about CUSTOM theme:
    =========================
    When using the Custom theme for your personalized branding theme, please make sure all the files are present and named as they are within the folder, such as Custom.reg, Custom.theme, Custom_Badge.bmp...

    If you look how the Custom brand folder layout is named within the OEM's.7z you can see the naming required.

    Changing any names to something other than shown will cause MRP to flag up an error and ignore the Custom Theme, this is to prevent errors within the theme on your installed OS more so with Windows 10 as it can be fussy on what is needed.

    For older OS's any parts not required will be ignored by the theme manager in the OS.

    It was easier to have one preset block of files for all OS's than to have separate ones for each OS then the theme manager can discard ones it not use automatically.
    My howto/readme writing isn't the best. :p

    I know a updated set of information will be needed that is more easier to follow. Any offers to help write a howto/readme set of files?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    @DMDraegon could you upload your new custom folder and i can take a look and see if anything is not right?

    I know the custom theme part works as i have used it myself, also Enthousiast has too. :g:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. DMDraegon

    DMDraegon MDL Novice

    Apr 8, 2015
    17
    6
    0
    CUSTOM is attached.
     

    Attached Files:

  14. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    thanks just taking a look now...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    Which OS are you using? 7 or 10? although it shouldn't matter as MRP will adjust , but wanted to make sure i have the same OS as you was trying. Edition not matter (apart from 7 Starter maybe Home Basic as they have a mind of their own lol)...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. DMDraegon

    DMDraegon MDL Novice

    Apr 8, 2015
    17
    6
    0
    I'm using a modified Windows 7:
    1. Orignal english base x64
    2. Through NTLite: Addes a few language packs (multiple languages spoken in the country I live in).
    3. Removed ei.cfg file
    4. Through Update7 Integrator added updates to each edition using Simplix update pack
    5. Also added USB3.x drivers through Update7 Integrator
    6. Integrated driver packs from driverpacks.net for chipset, wlan, lan x64 latest stable release (2012).
    7. Added $OEM$ customisation for theme through Multi-OEM/Retail Project {MRP} - Mk3
    8. Used custom icon for autorun and updated autorun file
    9. Removed sample media files from windows (sample music, images, video)
    10. Added my computer and user folder on desktop
    11. Did driver and update cleanup (not possible te remove updates) to reduce size.

    I do this once a year where I update everything, I got everything working fine except the theme customisation discueed here.
    It could be that something I did somewhere else broke this but I can't figure out what.

    The computer which it gets installed on:
    A Lenovo computer which has a Win 7 Pro SLIC
    Want to activate the Win 7 Pro SLIC (works) but with using custom theme.

    I read your updated text for your redme and it's much better :)
     
  18. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    Glad your not using a Gen2 ISO :p they cause all sorts of problems.

    I doubt any of your edits will affect MRP as you not removing any elements that affect theme stuff...

    My writing skills with help files isnt brilliant, i can write the programs its the putting the details into easy terms where i fail at :p
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    3,032
    7,115
    120
    just realised im installing w10 pro :rolleyes: it should not matter what OS as the custom theme is applied in the same way...

    I had enough of installing 7 the past few days when testing the MRP :p
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. DMDraegon

    DMDraegon MDL Novice

    Apr 8, 2015
    17
    6
    0
    I made my USER.BMP 124x124 pix based on your text in this file:
    Info about images


    ============================================
    File Name Pixels (H x W)
    ============================================
    Name_BADGE.BMP 120 x 120
    Name_BADGE.PNG 240 x 100
    Name_BAR.BMP 120 x 50
    Name_MCE_LOGO.PNG 90 x 45
    USER.BMP 124 x 124
    USER810.BMP/USER810.PNG 448 x 448
    ===========================================================================================

    Is it 124x124 or 128x128 now?
    :confused:

    By the way, the old version I have is just working fine...