Multi-OEM/Retail Project {MRP} - Mk3

Discussion in 'MDL Projects and Applications' started by mxman2k, Oct 15, 2016.

  1. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,686
    5,860
    90
    oops :oops: its a bug...

    Basically the CPUID is not defined and i somehow added an extra " (quote mark), which confuses the echo command. :oops:

    Have fixed that now for the next release, thanks for letting me know.

    Most likely VM software not copying over the CPUID from the host. Vbox ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,826
    2,446
    90
    Yep, VBox. It does some strange things, sometimes.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jcipher

    jcipher MDL Novice

    Nov 13, 2012
    2
    1
    0
    Is there a bug on the latest version for Win 7 64bit? It gets stuck at setup is preparing for first use with full cpu usage for find.exe. Using the previous version seemed to work fine.
     
  4. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,686
    5,860
    90
    #4805 mxman2k, Feb 27, 2019
    Last edited: Feb 27, 2019
    (OP)
    @ZerOx16x

    Strange that on VMware (Workstation/Player) v12 to v15 the insider build 18346.1 x64 'hangs' on the first logo screen and no spinning dots...

    On Hyper-V it will install ok from what i have seen.

    I am wondering if it is a Intel CPU issue as your logs show AMD FX CPU and it has installed fully on VMware, not sure of version of your VMware, v12 ?

    The build appears to install ok on a non VM in some cases.

    :g:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,686
    5,860
    90
    #4806 mxman2k, Feb 27, 2019
    Last edited: Feb 27, 2019
    (OP)
    Yes there seems to be a bug for w10 - (Maybe w7 too if have latest set of updates installed), i thought it was just on Virtual Machines (not M$'s Hyper-V as that appears to be ok).

    It has been mentioned about w10 insider build here and a few people have noticed this.


    MRP not use Find.exe as such, findstr.exe yes and other ways to search for something.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. jcipher

    jcipher MDL Novice

    Nov 13, 2012
    2
    1
    0
    Thanks. I might have installed it once on my laptop but I may have left it for a long time or didn't use the script. Installing it again on VM and laptop and I didn't have the patience to wait. I had originally thought it was slow due to integrated updates.
     
  7. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,686
    5,860
    90
    I am sure it is not the project as it has installed ok with a AMD CPU as can be seen here.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. ZerOx16x

    ZerOx16x MDL Member

    Oct 28, 2013
    141
    201
    10
    VMware Workstation v15 latest update.
     
  9. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,686
    5,860
    90
    I was sure it not be MRP as when i tested the 18346.1 x64 build last night with no MRP it still hung at the logo.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    19,416
    25,777
    340
    Yep, the problem is on the MSFT side, all iso's boot, except x64 18346.1, on VMWare.
     
  11. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,826
    2,446
    90
    Strange, VBox worked fine (on AMD Host).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,686
    5,860
    90
    MRP 110 is now at Baseline Candidate 2 stage and almost ready for release. :)

    Quite a few little changes done here and there, details of which will be shown in the summary/change log.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,686
    5,860
    90
    MRP v110 has been uploaded, 2nd post download link, password and hashes updated. :)

    + Added new option for SSD Tweaks. If this option is enabled on a normal HDD then the OS may slow down over time. You can revert this option via the revert script within 'Optional\Misc_ExtraScripts\General_All_Kernels' folder.

    + Updated some log entries to be clearer in explanations.

    + For RS5 with a CU/UBR of 316 or later the 'Turn Off Background Apps' option is no longer auto turned off, if your RS5's CU/UBR is less than 316 then the auto disable is still active.

    + Updated the Creator/Editor with the new SSD Tweaks option and some slight re-wording on some of the options.

    + Updated ready for .Net 4.8.x and 20hx detection.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...