Need help to recover bios on a Sony Vaio after a bad flash

Discussion in 'BIOS Mods' started by il cao, Nov 15, 2011.

  1. il cao

    il cao MDL Novice

    Oct 22, 2011

    I have a problem with my Vaio VGN-CS390J (Insyde H2O bios)...I asked for a modified bios to enable hidden menus of my laptop in the proper section of the forum; a user gave me a link for the modded bios and necessary program to update it but i think something went wrong.
    I run InsydeFlash and the hit Start button;seems everything was fine but after flashing completed the program quit himself and didn't reboot my laptop (i waited a couple of minutes) so i manually did it;but after reboot operating system won't ever boot up(says that some changes were made in hardware or software and i can't even load windows recovery procedure),i can still enter bios but nothig is changed(same menu).I tried to make a fresh install of windows but i get an error "bios in not ACPI compliant...";I can boot the laptop in dos with a bootable usb key but if try to flash the bios with flas**t.exe i always get the error "FADT not foud".I also tried to enable bios recovery procedure but all the common keys combinations doesn't work.Is there something else i can try to restore my bios?