Net FrameWork 4.8 refuses to get installed in old Win10 version

Discussion in 'Windows 10' started by spinalgr1998, Nov 9, 2020.

  1. spinalgr1998

    spinalgr1998 MDL Member

    Oct 16, 2014
    203
    7
    10
    Hello .. I have a machine with windows 10 1151 [Version 10.0.10586] . I dont wanna to upgrade to the latest version of windows 10.

    My problem is that Net FrameWork 4.8 refuses to get installed.

    Any fix ?
     
  2. BAU

    BAU MDL Addicted

    Feb 10, 2009
    846
    1,651
    30
    #2 BAU, Nov 9, 2020
    Last edited: Nov 10, 2020
    .NET Framework 4.6 - comes with windows 10
    .NET Framework 4.6.1 - comes with November Update (Version 1511)
    .NET Framework 4.6.2 - comes with Anniversary Update (Version 1607)
    .NET Framework 4.7 - comes with Creators Update (Version 1703), requires 1607 and up
    ...
    .NET Framework 4.8
    - comes with May 2019 Update (Version 1903), requires 1607 and up
    It's borderline-impossible for a casual user to install higher .NET versions than supported
     
  3. xinso

    xinso MDL Guru

    Mar 5, 2009
    4,860
    6,693
    150
    Do you know how to install OFFLINE? (from WinPE or WinRE environment?)
     
  4. BAU

    BAU MDL Addicted

    Feb 10, 2009
    846
    1,651
    30
    Well that's cheating :) And you can fool the installer, but then in practice .net applications will behave unpredictably when using winforms, high dpi etc.
     
  5. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,303
    811
    90
    Why do you need to install things that your system doesn't need and will never be able to use?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,303
    811
    90
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. spinalgr1998

    spinalgr1998 MDL Member

    Oct 16, 2014
    203
    7
    10
  8. nosirrahx

    nosirrahx MDL Addicted

    Nov 7, 2017
    577
    252
    30
    Try to installing .net 4.8 on Windows 7 without SP1. It also won't work and for the same reason.

    Operating systems get updated over time and certain updates include new compatibility.

    Refusing to update an OS has certain drawbacks.

    BTW, .net 5.0 is about to drop, so more incompatibilities will be on their way.
     
  9. xinso

    xinso MDL Guru

    Mar 5, 2009
    4,860
    6,693
    150
  10. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    4,145
    4,002
    150
    Technically, Windows 7 is more recent than Windows 10 1511. There are platform updates, occasionally bringing the old OS a bit more up-to-date. And MS decided that NET 4.8 can run on Win7 fully updated.

    It has been a long time 1511 has seen any updates, so, NET 4.8 doesn't target it.
     
  11. spinalgr1998

    spinalgr1998 MDL Member

    Oct 16, 2014
    203
    7
    10
    could you upload a gif tutorial of how you did it ?
     
  12. erpsterm35

    erpsterm35 MDL Expert

    May 27, 2013
    1,018
    568
    60
    .NET 4.6.2 also installs & works on 1507 LTSB 2015 as I tried that myself on a test machine running LTSB 2015 months ago

    maybe send xinso a PM to see if he can actually prove that it works
     
  13. BAU

    BAU MDL Addicted

    Feb 10, 2009
    846
    1,651
    30
    yeah it's wrong info. I actually have 1507 right now with 4.6.2 fully supported
     
  14. spinalgr1998

    spinalgr1998 MDL Member

    Oct 16, 2014
    203
    7
    10
    could you explain please ?
     
  15. erpsterm35

    erpsterm35 MDL Expert

    May 27, 2013
    1,018
    568
    60
    did you send xinso a PM like I told you a few weeks ago?
    I don't see him here much so he may not give an explanation in a post
     
  16. spinalgr1998

    spinalgr1998 MDL Member

    Oct 16, 2014
    203
    7
    10
     

    Attached Files:

  17. Mr.X

    Mr.X MDL Guru

    Jul 14, 2013
    7,067
    14,695
    240
    Yeah, he restricted his account. s**t.