Network Slow on Win10 RTM through Atheros Wifi

Discussion in 'Windows 10' started by phrunt, Jul 25, 2015.

  1. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    I have a Qualcomm Atheros AR945WB-EG Wireless adapter in my notebook, it was fine in Windows 8.1, It would transfer about 6mb/ps and the general network speed wouldn't slow down when doing so such as browsing and remote desktop.

    However... with Windows 10 the thing is terrible, If I copy a file through the Wifi adapter to another computer on the network I am getting about 1.5mb/ps and while it's copying the wifi access is slowed to a crawl, I can't even refresh a webpage, and the remote desktop session doesn't move at all until the copy is finished.

    I tried removing the drivers and letting Windows update install the driver, it brought down version 10.0.0.321 which was newer than what I had. It made no difference at all, I hunted the internet and the latest driver I could find was 10.0.0.115 so I tried that also, no difference, same result.

    Has anyone else got this network adapter and if so can they try replicate my results

    It does work fine with small tasks such as web browsing and downloading files off internet and remote desktop is fine, its just when you copy files through the network (maxing out the card) that you notice the problems.
     
  2. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,748
    1,959
    210
    I would use an WiFi Tracing tool and check out the used Channels in your area first and than, after done that, move your WiFi Channel to one which isn't used. If to many connections going of the same channel, everything will slows down.

    Also check all of your Network Settings incl. Firewall Settings!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Michelle68

    Michelle68 MDL Senior Member

    Jul 16, 2009
    465
    262
    10
  4. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    On the same machine with Windows 8.1 I get full working speed, no issues at all, I swap the hard drive over to the hard drive with Windows 10, slow again. It's not Wifi interference, I'm the only wifi in the area, I live on quote a large property so my neighbours are far away. All other computers are working fine.
     
  5. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    I forgot to mention, the new drivers you gave me the link to are the same ones Windows 10's Windows update put on, unfortunately they didn't solve it. They did stop it from dropping out, but they haven't fixed the speed issues.
     
  6. Don

    Don MDL Expert

    Jul 29, 2009
    1,366
    124
    60
    #6 Don, Jul 25, 2015
    Last edited: Jul 25, 2015
    probably not a driver issue, i have atheros and am using 10.0.0.318 and still get my max which is 120Mbit at all times.

    hmmm..i take that back, something happened in the last day and I am getting half of that right now..hopefully it's a fluke.
    it was a fluke, i reset the adapter and it is back to 120.
     
  7. Kouryu

    Kouryu MDL Senior Member

    Jan 19, 2011
    408
    111
    10
    Did you check on atheros.cz? It's the best site for the latest Atheros drivers
    That being side, you need to check for signal interference... download InSSIDer (use 1.2.8.0331 or 2.1.6.1394) and do a scan...
     
  8. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    Is yours an Qualcomm Atheros AR945WB-EG ?
     
  9. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    hmm it seems fixed by deleting the drivers and reinstalling from windows update while plugged into an ethernet cable.
     
  10. Michelle68

    Michelle68 MDL Senior Member

    Jul 16, 2009
    465
    262
    10