New Award BIOS tool for performing SLIC Insertion/Modification

Discussion in 'MDL Projects and Applications' started by andyp, May 5, 2009.

  1. genuineintel

    genuineintel MDL Member

    Apr 28, 2009
    234
    33
    10
  2. zort

    zort MDL Expert

    Feb 19, 2008
    1,105
    18
    60
    Please don't upload ones that haven't been released yet. Once it's been checked for bugs it'll be posted.
     
  3. andyp

    andyp SLIC Tools Author

    Aug 8, 2008
    1,672
    2,546
    60
    New version.

    v0.20

    ADD: Alternative methods (ACPITBL at end, Black EPA) for OEM7

    FIX: XSDT table not handled correctly in a few cases

    Andy
     
  4. XcopyBR

    XcopyBR MDL Member

    Apr 25, 2008
    176
    2
    10
    Thanks for the tip phrunt, I was about to test it on the same board.
    andyp, can you fix it for us ?
     
  5. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    502
    180
    How does it not work? Will not do ISA, does not flash?? What to fix??
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    i tried every mod option, fails every time, doesn't perform a mod. no point trying to flash as it never succeeds on the usual mod types you'd use and 0+2 completes a mod but if you flash you'll screw the board, from memory OEM7 also says its completed by if you flash you'll mess up the board, ISA and SSV3 both fail to complete a mod, tried many times to get it random, made no difference.
     
  7. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    502
    180
    I have that board modded with ISA and it works fine. I did mine manual. Try it that way...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    yea, i did a manual mod and it worked fine, i was just wondering why the tool fails and seeing if the bug in the tool / issue with the tool can be resolved.
     
  9. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    502
    180
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    yep, worked.. did you use the tool for that? weird why doesn't it work for me
     
  11. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    502
    180
    Used the tool. You dont use the ISA.BIN, just use the SLIC code like SSv1. It will fail with the ISA code....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. andyp

    andyp SLIC Tools Author

    Aug 8, 2008
    1,672
    2,546
    60
    ISA works fine. SSV3 didn't work as there was not enough space above &H10000 to insert random bytes to enlarge the main module. However you can also add these bytes in other strings, which v0.21 does.

    Andy

    PS - 911medic/zort - would another method be to do a SSV3 mod but instead of enlarging the main module to fill the gap insert a dummy, non-referenced oem7 module to pad??????
     
  13. andyp

    andyp SLIC Tools Author

    Aug 8, 2008
    1,672
    2,546
    60
    New version.

    v0.21

    ADD: Tooltips for options
    ADD: Parse ROM Holes and CPU microcode updates
    ADD: Option to remove first microcode update to make space (eg. for ISA or 0+2 mod)

    FIX: Rewrite module size adjust code. Fixes unable to shrink some modules for SSV3 and less likely to blank excess strings

    911medic - this should help with the problem you pm'd about - were it kept zeroing more strings than needed.

    Cheers,
    Andy
     
  14. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    502
    180
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. sebus

    sebus MDL Guru

    Jul 23, 2008
    6,226
    1,958
    210
    Thanks, but where is the ASUSTek Pegasus in this BIOS?
    Could not find it myself, also oembios.exe did not see it (it was the first to check, before asking)

    And as I said, the tool greyes out ALL, so can NOT input only SLP

    sebus