New Dell BIOS editing (boot logo)

Discussion in 'BIOS Mods' started by Googolplex, Aug 19, 2017.

  1. Googolplex

    Googolplex MDL Junior Member

    Aug 17, 2014
    52
    27
    0
    For my old Dell XPS 15 9530 I succeeded in editing the boot/splash logo. This was a laptop with an AMI APTIO UEFI.

    1. Extract the .rom file from the BIOS executable using the /writeromfile command line parameter (not required)
    2. Load the .rom file (or just the BIOS .exe) in Phoenix Tool
    3. In the DUMP folder, change the extension for all files to .bmp and find the boot logo
    4. Edit this logo and make sure all the file properties stay the same (color depth etc)
    5. Change the extensions back to .rom and finish in Phoenix Tool
    6. Flash the generated .rom file using AFUWINx64.exe
    7. Done

    On my new laptop, a Dell Latitude E7470, the BIOS is not of the same kind. I'm not sure what kind of BIOS this is to be completely honest. I like to refer to it as a Dell business computer BIOS. Attached you will find a screenshot of a BIOS page so you will probably know what I'm talking about.

    [​IMG]

    So here I began my journey in trying to edit the boot logo. My first task was trying to get to the .rom file. As you're all probably aware, the command line parameters (/writeromfile and /writehdrfile) stopped working with the new BIOS executables. Fortunately, also this .exe file can be loaded in Phoenix Tool. Also there is a Python script that can be used to decompress the BIOS: https://forums.mydigitallife.net/threads/i-present-you-a-tool-to-decompress-dell-uefi-bios.44785/.
    So now I can let Phoenix Tool create a DUMP folder in which hundreds of files appear, rename all those to the .bmp extension and find my boot logo. Edit this, rename to .rom and get a nice edited .hdr file.

    This is where my adventure hits a wall. To this day I have found no clue on how to flash this .hdr file onto my notebook. I've tried a lot:

    - Use the built in BIOS updated on the F12 boot menu --> Fail
    - Use the BiosUpdate.exe from Dell --> Fail
    - Find a recovery filename, place on USB and boot up with some key combo --> Fail
    - Use some dos tool for bios flashing, (Intel FPTW, and more but at this moment I fail to remember which) --> All of them Fail

    So I'm stuck here. I'm willing to try some tools on a Dell Optiplex 9020 which I think uses the same type of BIOS.

    If someone has succeeded in flashing a edited BIOS on a new Dell business system, please post your findings here and I will be forever grateful.
     
  2. aaronvesthp

    aaronvesthp MDL Novice

    Oct 25, 2013
    2
    0
    0
    Googoplex, did you every make this work? I'm trying to enable AHCI on a Optiplex 390. Ive got the HDR file and used AMIBCP to edit the sata mode but don't know how to load the Bios.HDR back in.



     
  3. sebus

    sebus MDL Guru

    Jul 23, 2008
    5,779
    1,730
    180
    OP390 dues to hardware used (Intel H61 Express Chipset Sata 2.0 ) can NOT work in AHCI mode
    No edit will make it happen! It is HARDWARE limitation!

    sebus
     
  4. Googolplex

    Googolplex MDL Junior Member

    Aug 17, 2014
    52
    27
    0
    We have bought an CH341 eeprom tool. Read the bios to a 16MiB .rom file, loaded it into Phoenix Tool and edited it. Then flashed the edited .rom file and the laptop didn't boot again. So, my first experience in hardware flashing a bios has been a bad experience. When anyone has any better idea's or successful experience, I'd love to hear it.

    Regards
     
  5. opssemnik

    opssemnik MDL Novice

    Sep 30, 2013
    15
    2
    0
    you cant modify the bios on IT, skylake has a protection against unsigned bios, any custom bios will cause failure to boot.
     
  6. bartsam

    bartsam MDL Novice

    Oct 12, 2017
    1
    0
    0
    Googolplex, hi.
    Have you tried to proceed it in another way, recommended in:
    \phoenixtool266\readme.pdf
    file?
    It says:
    For Dell: use either the modified EXE created by the tool or run the original BIOS EXE with
    ‘-readgzfile BIOS.GZ’
    (minus quotes) as command line

    So, it should be simple.

    Good luck,
    BartSam.
     
  7. Assimilator_X

    Assimilator_X MDL Novice

    Dec 15, 2017
    2
    0
    0
    Hi Googolplex,
    I have successfully edited my brand new Dell Latitude 14 Rugged 5414 uefi firmware on hardware level. As i am working in IT my mania is to back up everything i can including firmware dumps too. As they are more useful to me than a dell provided crappy exe flasher that i have no access at all. Like you mentioned i also could not find the way to unpack the exe. like i did on my older Alienware M17R2 and R3 models with AMIBios and InsydeBios. You need a more advanced tool than the CH341. Tools i used: a TL866A programmer a SOP8 Chip socket a SOP8 testclip and some a soldering station but when i flashed with the clip as the chip was still soldered onto the MainBoard i had to insert the battery back in the laptop to give power to the chip any other try was a failed attempt. The problem i was facing is that my ME was disabled and dell tech messed up my Service tag after a System board change. so my Service tag was no longer matching the label anymore. 1st i de-soldered the flash (Winbond 25Q128FV) 128mbit (16MB) and put it into my TL866A flasher and read it out. Now the fan part hex editor I am using BrakePoints HexWorkshop 6.8 officially. and started looking for the string of the messed up Service Tag. with option to find all instances and list all after that i find it. in a format of X.X.X.X.X.X.X separated with a dot hex 00 120 times in my firmware. Also i find the Owner tag and some very interesting parts that i will play in the future or remove etc etc so no protection at all Removed computrace and intel me firmware just by filling their section with 00h or FFh as it was useless anyway to me. My laptop is an i3 version and single bios MB now i soldered the second winbond 25Q128FV in no problem so far. And all this done on the latest firmware for the 14 rugged 1.14.0 just released last month.