Optiplex 755: Win7 activation + SLIC + BIOS trouble - help!

Discussion in 'Windows 7' started by JohnDoh, Sep 28, 2010.

  1. JohnDoh

    JohnDoh MDL Novice

    Feb 13, 2010
    2
    0
    0
    #1 JohnDoh, Sep 28, 2010
    Last edited: Sep 28, 2010
    Hello everybody,

    I've been trolling this forum for a while now, but this will be my first post. I'm not really sure where to post my issue, as it covers 3 different bases - moderators, feel free to move it if I'm in the wrong hood.

    I have 3 different Dells running Win7, which I'm all trying to manually activate offline: Optiplex GX270, Optiplex GX520, Optiplex 755.

    I'm using the method originally described by omdhar (forums.mydigitallife.net/threads/8357-Learn-amp-manually-activate-windows-Vista-amp-Windows-7-offline) and later revamped by Downloadix (forums.mydigitallife.net/threads/9126-HOWTO-Hacktivating-Windows-7-%28and-Vista%29-on-Dell-Optiplex-GX520-and-GX620-%28-amp-others-%29). I'm using Win7 RTM 7600.16386 32bit untouched.

    I'm leaving the GX270 for last. I got the GX520 activated easily without even worrying about the SLIC version. But now I'm totally screwed with the Optiplex 755.


    Let me explain (755):

    - I did a clean install with the original A10 BIOS, tried the above activation method, restarted, but no luck.

    - Then I updated to the modded A17 BIOS I found elsewhere on MDF, so to get SLIC 2.1, and then reinstalled a fresh copy of Win7 RTM. Then I tried the activation method again. Although, before I restarted Windows reported it is activated, once I rebooted I was back on the initial grace period. SLIC Toolkit 3.2 (forums.mydigitallife.net/threads/6925-SLIC-DUMP-ToolKit-x86-x64-%28Includes-PKey-amp-Cert.-Backup%29) showed that SLIC 2.1 was indeed present (M09)

    - So I scoured MDF again and found a thread explaining how it could be an issue with the ASSET TAG (forums.mydigitallife.net/threads/3486-How-do-OEMs-like-Dell-license-their-machines%97all-about-asset-tags). I pulled ASSET.COM from DELL ftp server, copied it onto a bootable USB stick, restarted in DOS mode, entered ASSET PASS:12/31, restarted into factory reset mode, and woop, ASSET TAG was reset.

    However, after this procedure Windows failed to start up. It got to the bit where the windows logo starts appearing on the screen and then crashed and auto restarted. I thought this was due to the ASSET TAG reset and proceeded to reinstall Win7 again. This worked, BUT, after running the activation method again I was still not activated.

    So just to check all was fine I ran SLIC Toolkit again, only to find I now had two SLIC tables present, version 2 and 2.1 - ver2 = M09, ver2.1 = QA09. When I ran SLIC Toolkit it popped up a window saying:
    There are 2 SLIC Tables in XSDT BIOS, the current SLIC table is NO: 1, select the next slic table? [YES] [NO]. Clicking YES reported (53) 20 01 00 02, clicking NO reported (53) 20 00 00 00

    So I re-updated my BIOS with the modded A17. Now I still have two SLIC tables present, but both are 2.1. I tried the asset tag reset again, but no luck, still 2 tables, still no activation.

    The end result is:
    - My BIOS XSDT contains 2 SLIC tables???
    - I cannot get Win7 manually activated
    - I don't know whether a Phoenix BIOS flash might help, or how.

    This is a very long winded story, but I thought better jot down the steps I took for better understanding.

    I would much appreciate it if anybody can help me out here, I'm so totally stuck and ready to burn the b*tch.
     
  2. vanhelsin

    vanhelsin MDL Novice

    May 29, 2010
    2
    0
    0
    have you tried installing a OEM dell copy of windows 7?
    i had a dell mini that came with windows 7 starter so i installed win 7 ultimate using the oem dvd and it worked wonderful so i would say use a oem dvd that is for dell
     
  3. shakeyplace

    shakeyplace MDL Addicted

    May 5, 2007
    861
    75
    30
    ok, first off I believe there amy be two seperate things going on here... let's try to get things back to original first, flash back to original bios, and do the ASSET tag thingy, check with SLIC tool, should only be 2.0 (original), if anything else, then you have a bootloader present, I would either try uninstalling bootlader with tools here at MDL, or repartition, reformat and re-install (I doubt all that would be needed but should eradicate any bootloaders, lol. then re-update bios with Dexterman's version of A17 HERE, reset the asset tag, check again with toolkit, should be just one. If that sounds like what you have done, then where did you get your copy of win7, resettting asset tag should NOT affect booting into your OS, It looks to me like the M09 is coming from the bios, it changes 2.0 to 2.1 depending on the bios you have installed, I believe the questionable one must be QA09, it is there no matter which bios version you actually have installed as for the ASSET tag utility, that really only causes troubles in most systems that were originally sold without windows (incomplete slic) if yours was originally sold with Vista or Seven or Xp then it usually does not interfere. there is a very limited number of systems that actually store the slic outside of the bios.
    If you still have troubles let me know exactly which files, installation disks, etc you are using.
     
  4. JohnDoh

    JohnDoh MDL Novice

    Feb 13, 2010
    2
    0
    0