P8Z77-V Premium Flash Back Broken

Discussion in 'BIOS Mods' started by SignedAdam, Oct 2, 2013.

  1. CodeRush

    CodeRush MDL Member

    Jun 20, 2011
    221
    667
    10
    Try another USB flash, some are not compatible with UBF.
    I have 3 compatible ones and 3 incompatible, so it's like 50/50 chance from my point of view.
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,709
    1,594
    180
    He has used it before so it should Work?
     
  3. SignedAdam

    SignedAdam MDL Novice

    Sep 30, 2013
    19
    0
    0
    It was going to happen one day, I tried getting flash back to work again, today, this time I written a "dot rom" file to large to my bios, after I found my motherboard just starts for 2 seconds, then turns off by its self, flash back is still up to its old tricks, (NOT WORKING" i see no way out now, other than buying a new bios chip,

    dont think im going to buy a asus board again... everything seems to have little problems here and there on this board
     
  4. RedDwarf

    RedDwarf MDL Novice

    May 22, 2008
    29
    14
    0
    This is now a very old thread but I do have something to add to it in case it becomes useful to someone. I have just become aware of this thread and I might of missed it B4.

    I have experienced problems with one of my P8Z77-V Premiums which showed problems with the Bios Flashback. On mine the Bios flashback button would very occasionally become fully lit despite me not touching the button. This would prevent my system from functioning and booting. The way that I fixed it was to depress the Bios flashback switch WITH THE POWER DISCONNECTED! Holding the switch it seemed to reset it for me. After doing that it would work and function/boot. The Bios flashback did seem to work after doing that in the limited amount of times that I used it.

    As you said, these boards are very flaky and do not work 100% in my experience. The USB ports are a PITA. The Bios flashback is a useful function though and I cannot imagine how anyone could flash a Bios on other makes without Bios flashback and without a CPU installed.