PC keeps waking up, windows update

Discussion in 'Windows 10' started by jhonsnow, Aug 15, 2015.

  1. jhonsnow

    jhonsnow MDL Novice

    Apr 5, 2015
    37
    10
    0
    #1 jhonsnow, Aug 15, 2015
    Last edited by a moderator: Apr 20, 2017
    So the last few days I have noticed my PC wakes up in the middle of the night to run updates and apparently there is a reboot schedule that wakes up the PC. Running the below command shows it's a task that runs whenever it feels like, I have deleted it, modified it but it keeps coming back. It is caused by forced windows update, i don't mind automatic download and install of updates but don't want it to force a PC reboot or wakeup my computer. Anyway to remove this so I can reboot and finish installing the updates when I want?

    Code:
    C:\WINDOWS\system32> powercfg -lastwakeWake History Count - 1
    Wake History [0]
      Wake Source Count - 1
      Wake Source [0]
        Type: Wake Timer
        Owner: [SERVICE] \Device\HarddiskVolume4\Windows\System32\svchost.exe (SystemEventsBroker)
        Owner Supplied Reason: Windows will execute 'NT TASK\Microsoft\Windows\UpdateOrchestrator\Reboot' scheduled task that requested waking the computer.
     
  2. Edwe

    Edwe MDL Member

    Sep 1, 2011
    143
    10
    10
    Mine did that once.
    Do you have Teamviewer installed?
     
  3. jhonsnow

    jhonsnow MDL Novice

    Apr 5, 2015
    37
    10
    0
    no i do not
     
  4. vacaloca

    vacaloca MDL Novice

    Nov 4, 2008
    20
    9
    0
    Control Panel -> Power Options -> Change plan settings -> Change advanced power settings -> Sleep -> Allow wake timers
    If enabled, disable it and that should stop the problem, I believe.

    (This is on Windows 8.1, but option should be similar/same in Win10)
     
  5. 3sidedcube

    3sidedcube MDL Member

    Oct 1, 2009
    115
    12
    10
    #5 3sidedcube, Aug 15, 2015
    Last edited by a moderator: Apr 20, 2017
    you will also notice that wake-on lan is enabled as well by default. :g:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. jhonsnow

    jhonsnow MDL Novice

    Apr 5, 2015
    37
    10
    0
    I actually tried that and had a pending update that required a reboot and even after disabling wake timers it STILL woke up the PC, even deleting the reboot wake task did nothing because it just kept coming back the next time it checked or updates. The only way I got around this this time around was actually let PC reboot and finish installing, but this is super annoying every time there is an update that needs a reboot.