Problems with Windows Update configuration

Discussion in 'Windows 10' started by JackSSA, Apr 12, 2017.

  1. JackSSA

    JackSSA MDL Novice

    Feb 23, 2011
    2
    0
    0
    Hello guys!

    I have had a problem after upgrading to Creators Update via upgrade assisstant, the option "Give me updates for Microsoft products", I uncheck it and it will be re-checked after reboot.

    My Windows Update settings are set to notify before downloading, as I have Windows 10 Pro, I configured it in Gpedit.msc.

    Is there any registry tweak so I can disable this function, it bothers me just having to download/hide the updates for the Office.

    Thanks to all.
     
  2. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    8,087
    26,958
    270
    #2 abbodi1406, Apr 12, 2017
    Last edited by a moderator: Apr 20, 2017
    admin cmd:
    Code:
    reg add SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\SLS\Programs\WUMUDCat /f /v WUMUDCATEnabled  /t REG_DWORD /d 0
    reg delete HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU /v AllowMUUpdateService /f
    net stop usosvc
    net stop wuauserv
    UsoClient.exe StartScan
    if that didn't work, try the tradition way
    admin powershell:
    Code:
    (new-object -c "Microsoft.Update.ServiceManager").RemoveService("7971f918-a847-4430-9279-4a52d1efe18d")
     
  3. JackSSA

    JackSSA MDL Novice

    Feb 23, 2011
    2
    0
    0
    Thank you friend, the second option works fine for me. :thumbsup:

    Thank you!