Recover HP 8540p Elitebook Bios after bad BIOS update, Please?

Discussion in 'BIOS Mods' started by edgar214713, Jun 18, 2014.

  1. edgar214713

    edgar214713 MDL Novice

    Jun 18, 2014
    1
    0
    0
    HP 8540p
    Hello Guys:

    I have a bricked HP Elitebook 8540p, HP won't help whatsoever. I am looking to restore the BIOS after a failure when upgrading to the new BIOS from Windows. I did run an older version of the BIOS with Andy's Tool on ROM.BIN,
    It Says:
    Recovery filenames are:
    SMC.BIN
    HEWLETT-PACKARD\BIOS\CURRENT\68CVD.SIG
    HEWLETT-PACKARD\BIOS\CURRENT\68CVD.BIN


    i have tried all method from this topic and others

    USB stick with
    Hewlett-Packard\BIOS\Current\68CVD.BIN
    Hewlett-Packard\BIOS\Current\68CVD.SIG
    SMC.BIN

    or with all caps lock
    or with 68CVD.BIN and 68CVD.SIG in root folder

    and it only creates the DUMP Folder, BIOS0.bios, and BIOS5.bios. It won't do the SMC or BIN and SIG files mentioned. Can someone point out what I am doing wrong please? or other steps to restore this laptop's BIOS? Any help is appreciated.
     
  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,574
    15,381
    340
    #2 Tito, Jun 18, 2014
    Last edited: Jun 18, 2014
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. madpoo

    madpoo MDL Novice

    Aug 7, 2014
    1
    0
    0
    Following these Instructions from the post
    "
    Resolved, after several days and countless number of methods and flashing

    simple solution is that i downloaded first published bios from 2010 for this model

    Steps are simple


    1. You need USB stick (FAT32, not bootable)

    2. Download from HP your bios update (extract them with win rar or 7z)
    (then extract file from ROM package, rename Rom.bin and efibios.sig according to your number of bios - you can find them in ver.txt)

    3. Put files like this on USB
    Hewlett-Packard\BIOS\Current\68CVD.BIN
    Hewlett-Packard\BIOS\Current\68CVD.SIG
    SMC.BIN

    3 Start Laptop and press Windows key + B (about 3-5sec)
    When you see that something read data from USB release keys
    (it's all about feeling when you need let off this keys, so probably you need to try several times)

    4 After 1-2 minute laptop will restart and you get error (press enter)
    5. From this step further is all easy (your OS is booting )

    I don't know why last two version of bios have not worked in this step, but first release have

    (and latest version of bios just won't install, i have tried several methods, one time i have boot screen with success upgrade,
    but after restart laptop is stuck for one hour, and then i just repeat restore which is described before)
    "


    I did not know where to get the SMC.BIN file.

    When I do the Windows key + B my laptop keeps resetting and this cycle loops. I have tried multiple times to let go when the USB is flashing (being read).

    Any other suggestion would be greatly appreciated.