request :how can i disable windows defender automatic updates- on windows 10-10049 ?

Discussion in 'Windows 10' started by akhmedtaia, Apr 9, 2015.

Tags:
  1. akhmedtaia

    akhmedtaia MDL Senior Member

    Nov 2, 2013
    486
    125
    10
    #1 akhmedtaia, Apr 9, 2015
    Last edited: Apr 9, 2015
  2. Smorgan

    Smorgan Glitcher

    Mar 25, 2010
    1,854
    1,029
    60
    #2 Smorgan, Apr 9, 2015
    Last edited by a moderator: Apr 20, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. akhmedtaia

    akhmedtaia MDL Senior Member

    Nov 2, 2013
    486
    125
    10
    #3 akhmedtaia, Apr 9, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)
  4. Smorgan

    Smorgan Glitcher

    Mar 25, 2010
    1,854
    1,029
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. GSDragoon

    GSDragoon MDL Novice

    Jul 2, 2011
    3
    0
    0
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinDefend

    Set "Start" to "4" and reboot. The service should no longer start and won't update.
     
  6. Smorgan

    Smorgan Glitcher

    Mar 25, 2010
    1,854
    1,029
    60
    We already tried that with cmd man using the automated means to set service using reg add. It is much more efficient and means we don't have to do registry diving.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. GSDragoon

    GSDragoon MDL Novice

    Jul 2, 2011
    3
    0
    0
    It's a little unclear, but it sounds like that doesn't work or requires additional permissions. Manually going to the registry key didn't require anything other than running regedit as an administrator.
     
  8. The_Guardian

    The_Guardian Contributor

    May 7, 2012
    2,003
    6,701
    90
    Another thing you could try if only needing access to one specific reg file is right click on the folder needed in registry which holds the key you wish to change and goto permissions, see if everyone is listed...if so then make sure all boxes are checked and save it. If not seeing everyone listed then add it and when created check all boxes and save. You should then be able to change what you need. When finished editing the registry remove or change permissions for everyone and you are done. It might work but if your permissions are messed up to begin with then you need to fix that first.
     
  9. WildByDesign

    WildByDesign MDL Addicted

    Sep 8, 2013
    636
    295
    30
    #11 WildByDesign, Apr 9, 2015
    Last edited by a moderator: Apr 20, 2017
    This was already discussed and a workaround was found. I'll dig it up from the main thread and update this post accordingly.

    EDIT: From Ace2 (http://forums.mydigitallife.net/thr...ch-build-(10049)/page41?p=1013552#post1013552)

    This was the only workaround that worked for me. Thanks to Ace2 for this suggestion. This stopped the service from running and also stopped the daily updates for Windows Defender as well. Permissions to change the service to Disabled is still Access Denied, though. But the workaround does switch service to Manual and it no longer runs. So at least temporarily for this build, it gets the job done. :cool:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...