.rom-file too big for bios-chip? how do I extract the file I need?

Discussion in 'BIOS Mods' started by ZeroPod, Oct 2, 2014.

  1. ZeroPod

    ZeroPod MDL Novice

    Oct 2, 2014
    Hello everyone,

    I have bricked my Samsung Series 9 notebook (np900x3a) while trying to restore it using a backup I made. The problem was it never rebooted most likely because I fooled around with the UEFI/legacy-mode.

    I now want to swap the bios-chip with a new one. The problem is that, although I extracted several .rom files from the samsung updater.exe neither of them has the right size. The file I think is most promising has a size of 2.621.440 Bytes or 2.5MB. The Chip on the motherboard however is a Macronix MX25L5121e which has only 512KB of space.

    I tried to extract the file I need with the Phoenix Bios Tool 256, and ended up with a file of 1.322.569 Bytes, so roughly half the size but still not the file I can flash on a new chip.

    I hope someone can give me a hint how to get the file I need for flashing.
    Thanks in advance!