S3 resumes only works once

Discussion in 'Windows 7' started by redan, Mar 3, 2010.

  1. redan

    redan MDL Novice

    Sep 23, 2007
    24
    0
    0
    Hi to any experts out there willing to help;

    I had Vista MC on my machine with a modded BIOS and suspend worked like a charm. I then installed Win7 MC with a modded BIOS 2.1 SLIC and now, I can get my machine to resume from suspend once and then when it is suspended again (and again and again), it reboots when coming out of suspend and loads the hibernate file, almost as if it has done some kind of shutdown instead of sleep. The MC will not wake to record any schedules either.

    I have reverted back to an original firmware but it still doesn't wake from sleep correctly after the first time. I then installed Vista with the modded 2.1 slic BIOS but still the same issue.

    I have a gigabyte EP45T-DS3R and tried F3 and F4c using SSV3, OEM7 and ISA method for inserting the SLIC.

    Help me please please please, I don't know what to do to get this working again. If you are also having the exact same issue or are not with an EP45XXXXX gigabyte motherboard and a modded bios, please let me know your exact config.

    Thanx so much.
     
  2. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    Enable hybrid sleep in your sleep settings.
     
  3. redan

    redan MDL Novice

    Sep 23, 2007
    24
    0
    0
    It is enabled. The interesting thing is that when I disable it and the system resumes, it goes into the bad shutdown screen and asks for a boot normal or into safe mode.

    By the way, I did put Vista back on but still had the issue. This all started when I went to 7 with a 2.1 BIOS.
     
  4. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    If automatic restart on system failure is enabled, it will automatically reboot the machine after a critical failure. To disable, right click on My Computer and select the Properties command from the resulting shortcut menu. When you do this, you will see the System Properties sheet. Click the Advanced tab and click the Settings button found in the Startup and Recovery section. Finally, deselect the Automatically Restart check box and click OK. This way instead of auto reboot you may get a BSOD which'll help debug.
    Also make sure Wake on LAN is disabled.
    Also check your event log for clues on whats going on.
     
  5. redan

    redan MDL Novice

    Sep 23, 2007
    24
    0
    0
    Will try your great suggestion of getting the BSOD, however I have gone through the event viewer and no indication there of what has happened.

    Will report back in 24 hours.
     
  6. redan

    redan MDL Novice

    Sep 23, 2007
    24
    0
    0
    Well I have to say, it was not what I expected.

    Disabling the Auto Reboot feature had no effect and there was no BSOD on reboot. However, your second suggestion of disabling WOL did the trick. I have no idea why and it is clearly a driver issue as Vista had the same issue.

    What had happened was when I went to Win 7, I downloaded the latest version of the Realtek Drivers and used them again when I re-installed Vista, which is why it stopped working on Vista when it use to work in the past.

    Many thanks. You time is greatly appreicated.