Service Pack 1 (SP1) installation error: 0x800F0A12

Discussion in 'Windows 7' started by TheDevilYouKnow, Feb 26, 2011.

  1. TheDevilYouKnow

    TheDevilYouKnow MDL Junior Member

    Oct 27, 2009
    61
    0
    0
    I was trying to install SP1 today and got this error :



    Windows 7 and Windows Server 2008 R2 Service Pack 1 (SP1) installation error: 0x800F0A12

    If you receive error "0x800F0A12" when trying to install Service Pack 1 (SP1) for Windows 7 or Windows Server 2008 R2, it means the installer can’t access the system partition of your computer’s hard disk to update files.

    Usually, this partition is accessible to Windows (although you can't browse it in Windows Explorer). However, in some situations, access to the system partition might be blocked after Windows has started. For example:

    The system partition isn’t automatically mounted, or made accessible to Windows, during startup.

    A hard disk containing the system partition was removed prior to beginning SP1 installation.

    Windows is running on a storage area network (SAN), and access to the system partition has been disabled.

    A disk management tool from another software manufacturer was used to copy (or clone) the disk or partition on which you’re trying to install SP1.


    My system is dual booted with Ubuntu Linux (10.10) on a completely separate physical hard drive. I also have a modded bios instead of a bootloader for Windows 7. I tried the mountvol /E command inside a dosbox (ran as admin) to no avail. I am wondering if perhaps the GRUB loader is interfering in some way but I do not know for sure.

    Is anybody else running a similar rig and/or having the same problem? I am downloading the SP1 update from MS and am fully validated already.

    Any suggestions or help at this point is greatly appreciated.

    Thanks !


    TheDevilYouKnow.
     
  2. kt_haddock

    kt_haddock MDL Novice

    Nov 29, 2007
    40
    3
    0
    Run DISKPART from run
    automount enable
    REBOOT
    Try again !

    Thank me :worthy:
     
  3. TheDevilYouKnow

    TheDevilYouKnow MDL Junior Member

    Oct 27, 2009
    61
    0
    0
    Thanks to you both,
    ...But I fixed my own problem by experimentation. I unplugged the Linux drive and attempted the installation again and met with success! I do not know for sure but I suspect that the GRUB boot loader interferes with the proper installation of the patch.

    Thanks again!



    TDYK.
     
  4. thomaspenwell

    thomaspenwell MDL Novice

    Mar 6, 2011
    1
    0
    0
    this error might occur if you have third-party bootloader (like GRUB).

    search Disk Management and run it.

    Find any partition which has 'system' flag, mark it as active. don't restart yet.
    remember to untick 'automatically restart' on the SP1 installer.
    before you restart, mark the previous partition or partition which has boot flag as active (in this case C).

    note: usually partition which has boot flag would have system flag too, but it might not be the case.
     
  5. campusr5

    campusr5 MDL Novice

    Mar 28, 2011
    1
    1
    0
    I have problems with 0x800F0A12 i find solution on this fixmywin.com/fix-windows-7-sp1-0x800f0a12-fffffffe-and-84c40007-installing-error/
     
  6. egm

    egm MDL Novice

    Oct 15, 2011
    1
    0
    0
    Nothing fishy (SORRY) about this information. I dont normally follow instructions on these forums but I had tried most other things.
    Ran DISKPART - typed "automount enable" and hit "enter" and it confirmed the instruction. Rebooted and SP1 installed without a hitch. I have had to register just so I could THANK YOU AND BOW.:):):):worthy::worthy::worthy: