sis 672m + 968 laptop doesn't support RAID or AHCI. SATA stuck in IDE mode -bios mod?

Discussion in 'BIOS Mods' started by chriz74, Oct 3, 2015.

  1. chriz74

    chriz74 MDL Novice

    Nov 1, 2009
    26
    0
    0
    #1 chriz74, Oct 3, 2015
    Last edited: Oct 3, 2015
    Hello. I have a laptop based on an ECS / Uniwill U50SI1 motherboard. The South bridge in this MB is sis 968 which should be very well capable of running SATA in AHCI mode however the bios has no option to modify the SATA operating mode.
    So I modified the bios to show a "PATA+SATA control id" menu that shows the MB is using ids 5513+1183 (pata ide + sata in ide emulation mode). You can set the pair as 5513+1184 (pata ide + sata raid) or 5513+1185 (pata ide + sata ahci). However when I set one of those the bios reverted to 5513+1183 hence no ahci.
    I then thought maybe I needed also an option rom for sis raid in the bios, so I extracted one from an AMI bios and inserted it in the Phoenix bios with Phoenix bios editor, built the bios, flashed but still no raid options or ahci.
    I can't find any Phoenix bios from some other laptops that have the raid option rom and I don't know if it's safe to replace the option rom named "other" or if there's other mods to be done to other modules in bios.
    Does anyone have a clue?

    Here's original bios:

    kfgl.hasee.com/bios/bios_nb/U40SI/U40SI_R1.16.04.rar

    and here's my modded one:

    dropbox.com/s/9vocxpei55604kv/USI11604-MOD-IDE-AHCI-CHIPSET-RAID.ROM.zip?dl=0

    i.imgur.com/VRnKFGV.jpg
     
  2. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,636
    1,917
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,263
    1,422
    180
    or in the classic hardware with crap chipsets