Slowing down file copy on Windows Server with 10Gbit

Discussion in 'Windows Server' started by Bob.D, Jul 27, 2021.

  1. ch100

    ch100 MDL Addicted

    Sep 11, 2016
    699
    596
    30
    This is what I am getting on Wi-Fi between an old laptop with i7 Sandy Bridge, 16GB RAM and Crucial SSD Win10 19044.1149 and a Synology NAS connected to the switch via 1GB LAN and HDD WD Red in RAID 10.
    No special tuning done.

    copy.jpg
     
  2. atgpud2003

    atgpud2003 MDL Senior Member

    Apr 30, 2015
    306
    40
    10
    WOW, Well Honestly, I have FreeNAS with Gigabit LAN with 8GB RAM, Intel Duo Core2 with 6 HDD RAID (3TB Total) when I copy from my desktop base Windows 7 Pro with Gigabit LAN and transfer 4.2GB ISO data and I get 112MB/sec transfer for under 20 seconds on each machine with SSD and hard drive mix.. My PC runs 16GB ram with Windows 7, My NAS was 8GB of ram..
    Some of you had trouble getting 10g speed, change to Cat6a directly to 10G nic from computer X cover cable Cat6a to 10G Nic and should be much higher than 1GB to 4GB per/sec..

    ATGPUD2003
     
  3. Bob.D

    Bob.D MDL Novice

    Mar 22, 2010
    43
    3
    0
    I use cat7-cable, still I only get kinder-schokolade in one direction...

    index.jpg
     
  4. DrunkF

    DrunkF MDL Junior Member

    Jun 15, 2010
    58
    14
    0
  5. Bob.D

    Bob.D MDL Novice

    Mar 22, 2010
    43
    3
    0
    @DrunkF Thanks. There are people not even getting gigabit speeds. But I will not get "new" hardware. Also I have plenty of RAM. To me it looks like Windows becomes trashy... They don't fix stuff and don't move more options to the GUI. Instead they make edges round.
     
  6. Verified

    Verified MDL Novice

    Jul 7, 2015
    7
    3
    0
    If you push a file to a share you leave it up to the remote machine to balance caching and writing. In my server the cache fills up almost as fast (5 gbits) as yours. Only when it runs out of memory the writing is given priority. MY WORKAROUND: To bypass the cache I remote into the server and pull my files from the client. My transferred bits go straight to disk. This is probably why your "other way around" performs as expected.

    You can visualize both scenarios with "perfmon". Add the cache, physical disk and network interface counters.
     
  7. acer-5100

    acer-5100 MDL Addicted

    Dec 8, 2018
    712
    460
    30
  8. haber123

    haber123 MDL Novice

    Nov 5, 2009
    12
    7
    0
    I disable digitally sign communications in local security policy, disable all offloading on the NIC, set congestion control to ctcp and can get a file transfers on 1 Gbs network into the low 900 mbps without any variance. Disable Nagle's algorithm helps a little.

    SMB setting in Lanman parameters helps too.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

    "EnableAuthenticateUserSharing"=dword:00000000
    "ServiceDllUnloadOnStop"=dword:00000001
    "restrictnullsessaccess"=dword:00000001
    "autodisconnect"=dword:00000000
    "enableforcedlogoff"=dword:00000000
    "enablesecuritysignature"=dword:00000000
    "requiresecuritysignature"=dword:00000000
    "Size"=dword:00000003
    "AutoShareWks"=dword:00000000
    "MaxWorkItems"=dword:00002000
    "MaxMpxCt"=dword:00001000
    "MaxRawWorkItems"=dword:00000200
    "MaxFreeConnections"=dword:00000064
    "MinFreeConnections"=dword:00000020
    "DirectoryCacheLifetime"=dword:00000000
    "FileInfoCacheLifetime"=dword:00000000
    "FileNotFoundCacheLifetime"=dword:00000000
    "MaxThreadsPerQueue"=dword:00000064
    "TreatHostAsStableStorage"=dword:00000001
    "SMB2"=dword:00000001
    "SizReqBuf"=dword:00004104
    "Lmannounce"=dword:00000001
    "ConnectionCountPerNetworkInterface"=dword:00000004
    "ConnectionCountPerRssNetworkInterface"=dword:00000008
    "MaximumConnectionCountPerServer"=dword:00000064
    "DisableBandwidthThrottling"=dword:00000001

    If anyone has other tweeks to increase network throughput I would love to see them.
     
  9. atgpud2003

    atgpud2003 MDL Senior Member

    Apr 30, 2015
    306
    40
    10
    Might be the drivers buggy?? Just asking..

    ATGPUD2003