[Solved] Advise needed: Bios Modding, will this work for me?

Discussion in 'BIOS Mods' started by AvilanceStudios, Mar 28, 2017.

  1. AvilanceStudios

    AvilanceStudios MDL Novice

    Mar 27, 2017
    3
    1
    0
    #1 AvilanceStudios, Mar 28, 2017
    Last edited: Mar 28, 2017
    I have with me a Lenovo T400 7417CTO with Bios version 7UET94WW (3.24). From my understanding, I think there is already a modded version of my BIOS according to this post: forums.mydigitallife.net/threads/5866-LENOVO-(IBM)-Bioses-especially-Thinkpad/page586?p=779313&viewfull=1#post779313

    I actually went as far as booting into DOS (with the files provided in that post) but I was hesitant to run any commands. For one, I wasn't even sure who the manufacturer for the BIOS on my board is, that is, until I ran the Universal Bios Backup utility and I suppose it is showing up as a "Phoenix".

    I'm not sure whether or not to trust that this program picked up the correct BIOS manufacturer because regedit does not mention Phoenix anywhere, but it does say: BIOS Vendor: LENOVO.

    Would that Bios mod work with my laptop and well... I guess the most obvious question at this point is, what command do I run in dos to get phlash16 and the included rom flashing?

    Thanks everyone, much appreciated!

    P.S: I would like to install an Intel Dual Band Wireless-AC 7260 Plus Bluetooth card and maybe it is also worth it to mention that I currently have this BIOS installed: download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/6quj19u6.exe (I noticed in the thread that they were using 7uuj49us, does this make a difference?)
     
  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,645
    15,572
    340
    @AvilanceStudios

    I've replied to your PM.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. AvilanceStudios

    AvilanceStudios MDL Novice

    Mar 27, 2017
    3
    1
    0
    UPDATE: Thank you Tito, you have assisted me in figuring this out and it is working like a charm. Just for fun, I decided to install a Dell Wireless WLAN 1397/1510 and it worked flawlessly. The only thing that I noticed was different was the Wireless LED didn't go crazy like it used to blink with the old card, now the light just goes on and THAT'S the way it should be haha, so it's a good side effect. Other than that, everything is working and I think I'm in the clear for ordering that Wireless AC Intel card.

    Just a Recap for those who were having the same issue as me, Tito was quick to point out that the driver download on the Lenovo site ending with u6 is actually just the x64 bit download of the original Bios. That's what you gotta do first, download the original bios for your T400 and make sure it will match the modded bios version AS WELL AS THE TYPE (in my case it was Phoenix and it was hiding under Lenovo branding). Depending on if your bios ends with 94 or 95 (if below 94, when you install original it will update to 94), just download the files mentioned in my initial post and get DOS on your USB via Rufus (DOS is used because it's possible windows services can hang the download which in that case, your computer would be f@$%). Then restart and copy over the ROM file (there is a folder for 94 and 95 containing the ROM, obviously choose the folder that matches your bios version) , the flash.bat, and the plash16.exe file to the root of the USB and you're golden.

    For this laptop, you push F12 to get to the boot list, then choose your USB flash drive from the list, you'll then see the DOS command prompt window. Type in without quotes 'flash' and then just wait. DO NOT unplug your PC or hibernate etc.... just leave it on and make sure you have enough charge/AC power connected. After it was done, it said that it was successful and I heard a long beep of success. It will ask to restart and you're done.

    For Those Who DO indeed....