[Solved] Asus Z97-Pro (WiFi ac) bios update fail

Discussion in 'BIOS Mods' started by trodas, Dec 21, 2015.

  1. trodas

    trodas MDL Member

    Jan 22, 2008
    223
    18
    10
    My Asus Z97-Pro (WiFi ac) have bios v2303:

    [​IMG]

    So I load the new bios (all the more recent bioses anyway) on USA flash:

    [​IMG]

    I picked up the latest one (v2702) and tried...

    [​IMG]

    ...to upload it, then I get "not a proper BIOS" message:

    [​IMG]

    NONE of the bioses I tested (v2401, v2501, v2601 and v2702) worked. All I download directly from Asus site:
    http://www.asus.com/cz/Motherboards/Z97PROWiFi_ac/HelpDesk_Download/
    ...so could SOMEBODY tell me, what is going on?!



    Next thing - let's try the mainboard function of USB BIOS Flashback - I put into the proper port (page 2-14 "bottom port supports USB BIOS Flashback") USB drive with file in the root directory, renamed by the BRenamerl.exe utility to "Z97P.CAP")

    After power up, I hold the BIOS_FLBK button for 3+ seconds and I expected to see 3 blinks of the LED and beggining of the flash proces, but ABSOLUTELY NOTHING HAPPEND.



    The last attempt to flash bios update on Asus Z97-Pro (WiFi ac) was my attempt to boot from USB flash. Formated as DOS bootable device (or DrDOS) and in both attempts failed. Even afer disconnecting both SATA devices (HDD + DVD).



    So the mainboard works, but it did not see the Samsung SM951 (MZ - HPV1280) M.2 128G SSD is not seen as device in bios or HDD prep programs like Mini Tool Partition Wizard Pro. Any help is need:

    [​IMG]

    ...perhaps it is just me, doing something wrong?
     
  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,213
    14,776
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. trodas

    trodas MDL Member

    Jan 22, 2008
    223
    18
    10
    Oh my... thanks! My epic fail, lol...

    Now I finally have the bios updated! I completely forget, that my mainboard is not "Asus Z97-PRO (WiFi ac)", but a "Asus Z97-PRO (WiFi ac)/USB 3.1" and that means, that I tried different BIOSes. Witch end up with the "impossibility to update" the bios.

    Now I running at bios v2702, yet the M.2 SSD (Samsung SM951) is still "not present" in bios, or for HDD prep program (Mini Tool Partition Wizard Professional) or visible for Windows 7 install:
    http://rog.asus.com/forum/showthread.php?81308-Asus-Z97-Pro-(WiFi-ac)-not-see-my-M-2-SSD-drive
     
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,264
    1,422
    180
    enabled M2 port in settings of bios ?