[SOLVED]HELP - How to "Force Reflash" Sony VAIO InsydeH2O ROM using Manufacturer's Tools

Discussion in 'BIOS Mods' started by thewaywardgeek013, Mar 25, 2018.

  1. thewaywardgeek013

    thewaywardgeek013 MDL Novice

    Jun 2, 2014
    2
    2
    0
    #1 thewaywardgeek013, Mar 25, 2018
    Last edited: Jun 24, 2018
    Insyde H2OFFT
    Sony VAIO SVE11125CVB
    Running updated BIOS ROM - R0150D8

    Let's get into the background as to why I want to flash the same ROM.

    So been having Issues with Date and Time initially due to CMOS Battery being dead, did not want to open laptop up as when I'm on Windows I can still change date and time for it. But lately been having issues with long POST on BIOS, it would eventually boot up, but would take 3-10 mins., I tried to go into "VAIO Rescue Mode"(via "Assist Button" when notebook is turned off) to check BIOS Settings, and lo and behold, can't get into it, tried the clear power thru the notebook by pressing power button for 1 min. and still to no avail, figured it might just be the CMOS Battery that's causing it, so went ahead and replaced it but still issue persisted. Researched that one possible solution to the issue is to reflash BIOS ROM as CMOS Battery being dead might have caused corruption to my BIOS. So went ahead and downloaded updated BIOS ROM from Sony Website. Ran it but gives error - "The system firmware is current, and does not need an update."

    So this where I am now. Tried extracting the Executable and running "InsydeFlashx64.exe" but still throws me and says Invalid Firmware. Tried setting up the platform.ini to disable "Platform_Check" and "Bios_Version_Check", but still no go, however did not try to "ForceFlash" because this might cause data loss on my BIOS, also one thing I discover is backed up current ROM (used "H2OFFT-Wx64" from "UDOOX86_B02-UEFI_Update_rel102" to backup current BIOS) is smaller than the one I am trying to apply.

    Hopefully some can shed some light on this issue.

    [UPDATE]

    After a bit of searching from the forums, found a post at "Bios Tools" Thread (Post #733) with parameters for "InsydeFlashx64.exe" OR "Insyde H2OFFT", just needed it to run with parameters "-forceit", and system will reboot and flash BIOS! Hope this helps someone out there!