[SOLVED] How to disable Device Performance & Health in Creators Update?

Discussion in 'Windows 10' started by ChaserLee, Apr 16, 2017.

  1. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    437
    93
    10


    Nah, it trims itself. Never had a slow down, never had fragmentation problems, never any issues at all because of not de-fragging. I am aware this this is a subject of controversy, still after all these years after the SSD made its debut, but I have chosen my method of running SSDs in my system, and it works well for me. Your mileage may vary....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    437
    93
    10

    Yep, it auto trims in a couple seconds, for sure!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,585
    5,333
    210
    #23 lobo11, Apr 17, 2017
    Last edited: Apr 17, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    32,077
    50,805
    450
    But how could the auto-optimizing be the cause of the led being lit-up for a long time if it only takes a few seconds?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    437
    93
    10
    The auto-trim wasn't causing the constant led-on situation. The built-in Windows 10 disk optimization program was causing it, for some reason. In other words, Windows was trying to defrag the SSD, and it wasn't working so well. AFAIK, the auto-trim function is built in to the toolbox software that ships with the drive, while the windows defrag is a program that gets installed along with Windows. Yes??

    Without me delving further into the inner workings of the new Windows update, all I know for sure is the results. As soon as I turned off Windows disk optimization on the SSD, the problem went away.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Snake_Eyes

    Snake_Eyes MDL Junior Member

    Mar 3, 2015
    80
    11
    0
    Is it not all about your SSD is getting a defrag, but just your second drives, if u still have those in the system, thats in in your sig ?
    Mostly those drives will be defragmented and can take a longer time (depends on how many its been filled)
     
  7. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    437
    93
    10
    Yes, I still have a total of 5 drives in my system, the System SSD, and 4 other 'traditional' hdds. However, I have the Windows Optimization turned off for all drives now. The reason is because I prefer to defrag the 'traditional' drives on a timetable of my own choosing. When it comes to my computer, I'm somewhat of a control freak. I want to control when, and which one, of my drives gets defragged at a time of my choosing. So under normal conditions, I would agree with your statement. In my particular case, not so much.....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Snake_Eyes

    Snake_Eyes MDL Junior Member

    Mar 3, 2015
    80
    11
    0
    Yea okay u turned it now off, but u had the problem, that after 6 min your hdd led was turned on and any hdd was used constandly.
    So thats why i asked, if some of the drives was been defragmended at that moment.
    I'm a control freak to, but i have still turned that defrag on, but only on the SSD, because it does only a trim, and it wont defrag it.
    Not sure why its now in defrag program, i thought windows itself would do trim the SSD after delete a file.
     
  9. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    437
    93
    10
    Yes, that could have been the situation, that any one of the 6 drives was being defragged, causing the led to stay on constantly. I do know that now it's completely turned off, I have not had that problem since... So, problem solved.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...