[SOLVED] Modifying SLC DMI on weird HP board (Foxconn Newark with Award BIOS)

Discussion in 'BIOS Mods' started by 24q6hr, Feb 21, 2011.

  1. 24q6hr

    24q6hr MDL Novice

    Feb 6, 2011
    37
    13
    0
    #1 24q6hr, Feb 21, 2011
    Last edited: Feb 22, 2011
    Hi folks,
    I have sort of weird board. It is MCP7AM04H1 (Newark) manufactured by Foxconn. According to the HP web it is used in one and only PC: Compaq Presario CQ5023IT, sold in Italy only, probably with (or without) Windows Vista. Based on MCP7A Chipset (Nvidia GeForce 9300 aka ION) with socket LGA775, no PCI slots, only PCI Express (three PCIe ×1, one PCIe ×16). It has an Award BIOS.

    I was able to save the BIOS from the board (on Italian HP web can be found one step older BIOS than was in my board, can be located only when choosing Windows Vista as your OS) and I was even able to modify it (Phoenix mod tools told me it's not Phoenix, Award mod tools successfully modded the BIOS and told me there is also SLIC 2.0 in Dynamic mode - I was able to replace it with SLIC 2.1, also in Dynamic mode, other mode was not available). I was even able to successfully upload the whole BIOS and the board still works ;) (using AWDFLASH.EXE v8.94).

    The problem is that the SLIC is somehow NOT enabled (probably in DMI). HP DMI tools are unusable with this board, IDEN.EXE returns errorlevel 0 (for those who now how the DmiFit.bat works) and no HP(anyting).exe file is able to support this platform (it says "platform not supported", or is not able to read or write SLP, says some Error 0x24 (not exactly the 24, I'm not able to remember the number during my switch from DOS to Windows ;).

    Is there a way to tell the board to enable SLIC? I mean ... is there a way to enable it on "general AwardBIOS-based" board? If so ... how? ;)

    Thanks very much.
     
  2. NoJuan999

    NoJuan999 Experienced SLIC Tool Operator

    Jul 31, 2009
    9,919
    1,933
    300
    #2 NoJuan999, Feb 21, 2011
    Last edited: Feb 21, 2011
    Try clicking on Cancel on the Pop-up in Awd Tool and then use ISA Method.
    That may work for you.

    PS
    Run SLIC Dump Toolkit and see whatr RSDT was used and use that SLIC 2.1 .BIN that matches the RSDT to be sure it works properly.
    OR
    Upload the BIOS to sendspace, mediafire or similar and post a screen of the Advanced tab from the SLIC Toolkit so it can be modded by someone here.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. 24q6hr

    24q6hr MDL Novice

    Feb 6, 2011
    37
    13
    0
    #3 24q6hr, Feb 21, 2011
    Last edited: Feb 21, 2011
    (OP)
    Thank you for quick reply.
    I tried the ISA method. That wasn't a good idea actually, I was then unable to enter setup ;). I think was a little bit lucky I was able to boot and restore the original BIOS ;).

    What about trying other methods? Can I just take it as a "trial and error" method? Or is there a big possibility of bricking my MB using particular method? (I'm just testing so one bricked board doesn't mean anything for me - it's soft of challenge ;)

    And here is my SLIC toolkit report: img718.imageshack.us/img718/7572/20110221231452slictoolk.png
    Edit: Original (not modded) BIOS here: mediafire.com/?8uhbfbdz7871xbv
     
  4. Serg008

    Serg008 MDL BIOS/EFI Guru

    Feb 23, 2010
    19,247
    8,509
    340
  5. 24q6hr

    24q6hr MDL Novice

    Feb 6, 2011
    37
    13
    0
    Thanks a lot, I call this success :)
    img811.imageshack.us/img811/5044/20110222092138slictoolk.png