[Solved] More BitLocker Madness!

Discussion in 'Windows 7' started by RASelkirk, Nov 5, 2018.

  1. RASelkirk

    RASelkirk MDL Member

    Feb 4, 2010
    187
    8
    10
    Hi All,

    I somehow managed to trash my bitlockered thumbdrive. Here's the sequence of events, best I can remember:

    • Went to access it today and found it was already unlocked, files fully accessible. Momentarily freaked out, then realized I must have somehow toggled the auto-unlock on my previous session. I have the keyfile for this.
    • Tried to find the "auto" switch, no "manage" in the context menu for the drive, had to use the BL app thru CP to deselect the auto feature.
    • Removed the drive and reinserted to see if it was still unlocked. No, it's locked. However, now my PW would unlock the drive but it's no longer accessible, Does not show a lock icon at all.
    • Removed & reinserted, tried changing PW. PW changed OK. Drive unlocked with new PW, still not accessible.
    • Selected "Turn Off Bit Locker" and drive went thru this process successfully. Still no files (insert disc in drive I) message.
    • Encrypted drive again with original PW, kept the keyfile (waaay different than the 1st file). Shows encrypted in BL CP, yet drive shows no lock icon(s) and is inaccessible.
    • Ejected drive, reinserted. Got the unlock dialog, entered PW (it took). Drive still has no lock icons and shows "I:\ is not accessible. Acess is denied".

    • Any tips before I bust out repair-BDE?

    • Russ
     
  2. Mr.X

    Mr.X MDL Guru

    Jul 14, 2013
    6,075
    13,645
    210
    toter-commercial-trash-cans-025596-01grs-64_1000.jpg
    :tooth:
     
  3. RASelkirk

    RASelkirk MDL Member

    Feb 4, 2010
    187
    8
    10
    Think I got it! Was able to use repair-bde to "recover" the drive to an img file, reformat the thumb drive, write the img file contents back to the thumb drive, then re-encrypt. All is good now. Have no idea how the thumb got corrupted as I'm very careful about ejecting the drive before physically removing it. One of those "Wonderful World of Windows" things, I guess...

    Russ