[SOLVED] Unlocker will not unlock file in use by 'system'

Discussion in 'Application Software' started by stayboogy, Sep 24, 2011.

  1. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    #1 stayboogy, Sep 24, 2011
    Last edited: Sep 30, 2011
    Unlocker program will not unlock any file that is in use by 'system'

    every time i try to unlock any file (mainly disc images) that is in use by 'system' Unlocker never finds any locking handle

    why is this??? is this a windows 7 incompatibility of the program???

    how do i fix 'system' from locking every disc image from deletion even when it is not being used by any program???


    [HOW IT WAS SOLVED: images must be unmounted from the daemon tools gui, not right clicking the image in "my computer" and clicking "eject." if image is not unmounted from the daemon tools gui, system locks the file.]
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. evlad

    evlad MDL Member

    May 23, 2011
    225
    175
    10
    Image is around 3~5GB ?
    maybe your AV check the file ... If you enable your AV to check archives, maybe it unpack all data from image to check and this is system call.
    windows itself have unpack capabilities (without winzip, rar, 7z you can unpack most of archives) and AV uses that system call.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    image can be 5mb and it still does the same thing...

    has something to do with daemon tools, but what i have no idea. there are no settings activated other than integration--no automount, etc. if i unmount an image it can not be deleted without either restarting the entire pc, or by mounting another image in daemon tools. as soon as another image is used, the previous becomes unlocked. it never once worked like this in XP and all the settings are the same for the program so idk wth is going on, but it's ticking me off something awful. despite the pleasures of aesthetics in 7 there's a bunch of nonsense going on in too many places...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. evlad

    evlad MDL Member

    May 23, 2011
    225
    175
    10
    #4 evlad, Sep 24, 2011
    Last edited: Sep 24, 2011
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. IronMaiden

    IronMaiden MDL Member

    Oct 27, 2009
    104
    9
    10
    Unlocker can delete (or move/rename) a file even if no handle was found. You didn't say if you tried that...didn't work either? I agree, though, it must be either some kind of virus/spyware scanner or virtual CDROM thingamajig.
     
  6. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Josh Cell

    Josh Cell MDL Developer

    Jan 8, 2011
    3,519
    7,112
    120
    The file probably is working with any service on the windows ...

    Try disable some services ...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    #8 stayboogy, Sep 30, 2011
    Last edited: Sep 30, 2011
    (OP)
    ...

    the windows dialogue says that it's being used by "system" and can't be deleted even when it's not being used.

    what service then?

    it has something to do with the way daemon tools lite works in 7, no doubt. i can have a completely identical system as far as is possible in XP (same software, same config) and this same thing will not be duplicated.

    still have no idea why...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    #9 stayboogy, Sep 30, 2011
    Last edited by a moderator: Apr 20, 2017
    (OP)
    well after a reboot i can always delete the file, so no need for safe mode. the file cannot be deleted if it has been mounted in daemon tools lite, then unmounted, and the pc has not gone through a reboot. even if i end "explorer.exe" and re-run it the file is still locked by system, even after logging off and logging back on. if i restart it can be delete no questions asked.

    as far as i know there is no so-called "ownership" on FAT32 drives or the files they contain, correct me if i'm wrong??? this is on a FAT32 drive...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. evlad

    evlad MDL Member

    May 23, 2011
    225
    175
    10
    #10 evlad, Sep 30, 2011
    Last edited: Sep 30, 2011
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. evlad

    evlad MDL Member

    May 23, 2011
    225
    175
    10
    win + R type REGEDIT
    find:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services

    try to find key with deamon tools ...
    this registry entry tell you the name of the service and where is located.

    good luck
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    there is no service associated with daemon tools at this key or any other daemon tools key.

    "system" is using the file... it's nowhere in use though. this is a windows 7 thing apparently. has something to do with all the nonsense file locations just can't figure out which one
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    716
    116
    30
    Finally solved!!!!!

    finally solved this bugger of a problem.

    i have been using right click and "eject" to unmount images instead of opening the daemon tools gui and unmounting that way. if image is not unmounted using the gui, system locks the image.

    finally, finally, finally...:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...