[Solved] Windows 10 Error 0x800f0922 when installing .NET Framework 3.5

Discussion in 'Windows 10' started by no_name86, Aug 2, 2015.

  1. no_name86

    no_name86 MDL Novice

    Nov 29, 2013
    #1 no_name86, Aug 2, 2015
    Last edited by a moderator: Apr 20, 2017
    Title says it all. I keep getting this error whenever I try to install .NET Framework 3.5 on Windows 10.

    I've tried both the Add Features and the sxs DISM command methods (I've also tried this in Safe Mode) but they still do not work. Could someone help me? Thanks in advance.

    Here's the DISM.log (replace the "(dot)" with "."): drive(dot)google(dot)com/file/d/0B9RIYKhXSa0GWFh0bGFkSmc5LW8/view?usp=sharing

    EDIT: Just solved it by downloading the cab package located in here: forums .mydigitallife. info/threads/57050-Windows-10-Hotfix-Repository?p=1106641&viewfull=1#post1106641 and running this in an elevated command prompt:

    dism /online /add-package /packagepath:D:\sources\sxs\microsoft-windows-netfx3-ondemand-package_1c89e2ded9ddd050dde8e723c5806704416dd363.cab
    where the packagepath is location of the downloaded file. After that .NET Framework 3.5 is enabled.