[SOLVED] Windows 10 higher DPI - Win8DpiScaling problem

Discussion in 'Windows 10' started by rafalek, Jul 18, 2015.

  1. rafalek

    rafalek MDL Novice

    Jun 19, 2012
    16
    17
    0
    #1 rafalek, Jul 18, 2015
    Last edited by a moderator: Apr 20, 2017
    Hello Everyone,

    I apologize in advance if this thread has been posted in the wrong place and kindly ask the mods to please move it accordingly if found so. I am present on the forums for quite some time, however I normally just read the content. I have searched the forums, but did not find similar thread anywhere.

    I am having issues with the DPI settings in Windows 10 and was wondering if one of you guys could help shed some light or offer tips to help solve my problem.

    The problem is related to the DPI slider setting that allows us to make various elements of the Windows 10 UI bigger by setting the slider to 125% position. That sadly also has a consequence of stretching the runned apps to a point where they become pixelated and blurry.

    In Windows 8.1 there was a setting called “Let me choose one scaling level for all my displays” which was completely satisfactory to me as it made so that non high DPI aware apps to ignore higher scaling and display in 100% scaling mode.

    My goal I would like to achieve is having DPI of 125% (120 dpi), while also having all the apps run in 100% scaling (96 dpi).

    I have searched the network for solutions and came across settings available via regedit HKCU\Control Panel\Desktop, mainly Win8DpiScaling.

    According to the documentation here*, when set to 1 it should de facto enable the flag “Let me choose one scaling level for all my displays” not present anymore in Windows 10 and grant the same behavior I am seeking for apps to follow.

    Sadly, it is not the case in Windows 10, even with it set to 1 and then custom DPI slider set to 125% the apps are still opening streached and blurry (in Windows 8.1 with this setting on, apps would open in 100% scaling and ignore the DPI setting, while other elements of the system UI were bigger).

    The only alternative that I found to make this work, is to set the Compatibility flag on every single application I run, which was not needed in Windows 8.1 with the “Let me choose one scaling level for all my displays” set.

    * unable to post links, here is the one in question: technet.microsoft.com/en-us/library/dn528846.aspx
    ** Guide that I tried but also did not work: tenforums.com/tutorials/5990-dpi-scaling-level-displays-change-windows-10-a.html

    I have also played with other values described here*, but to no avail.

    I was wondering if any of you experienced with the system could be so kind to offer me some tips, or maybe there is something I've missed?

    Thanks in advance!

    EDIT - Workaround posted by user Fra31 in post #3

    DETAILED:

     
  2. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,378
    459
    120
    Have you installed your system maker chipset and graphic drivers?
     
  3. Fra31

    Fra31 MDL Novice

    Jul 18, 2015
    3
    5
    0
    #3 Fra31, Jul 18, 2015
    Last edited: Jul 18, 2015
    Hi dud I've just found the solution. You have also to modify the key DpiScalingVer from decimal value 4096 to 4120, reboot and it works. Sorry for my english xD

    Edit 1: It works but after a reboot it returns to 4096, i don't know which application modify the value.

    Edit 2: I couldn't found who is the program that modify the value but I found a workaround. I create a script that, every time pc boot it edits the key value. You have to put the .cmd file in auto start folder. Here is the command, you also have the Win8DpiScaling value to 1 and the LogPixel decimal value to 120. Sorry for my english

    REG ADD "HKCU\Control Panel\Desktop" /v DpiScalingVer /t REG_DWORD /d 0x00001018 /f
     
  4. rafalek

    rafalek MDL Novice

    Jun 19, 2012
    16
    17
    0
    #4 rafalek, Jul 19, 2015
    Last edited: Jul 19, 2015
    (OP)
    Hey there,

    Thanks for sharing. I will have a look to see if the script will do the trick.

    I did experiment with the DpiScalingVer (this key was not present in the previous Windows) but each time after logging out this would reset.

    Will post when I test the script. Would be a nice interim solution provided it works.

    EDIT:

    Indeed it works as mentioned by you - thanks again Fra31!

    I will update the first post.
     
  5. Javagreen

    Javagreen MDL Novice

    Oct 23, 2014
    2
    0
    0
    Uhh is there a similar trick to downscale the DPI to lower points? I'd like to make everything smaller, like around 75-80% or so. I have a laptop and it's 1366x768 resolution just feels too less.
     
  6. Fra31

    Fra31 MDL Novice

    Jul 18, 2015
    3
    5
    0
    I think you can't go below 100% but you can make icons smaller.
     
  7. adric

    adric MDL Senior Member

    Jul 30, 2009
    465
    132
    10
    I tried this and it did not work for me. Check out the event viewer - it is still blurred. Do you see the same thing?

    mmc.exe is DPI unaware and everything related to it shows blurred fonts such as device manager, etc. When you look at the properties for mmc.exe there is no compatibility flag to set, so you are SOL when running at 120 DPI if the dpi unaware apps don't show this flag. Setting DPIScalingVer is reset when rebooting or logoff/logon.
     
  8. rafalek

    rafalek MDL Novice

    Jun 19, 2012
    16
    17
    0
    #8 rafalek, Jul 19, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)
    You haven't used the solution properly.

    In order for it to work, you need to make sure it is applied at each log on - either set it via batch file and drop to Autostart or use Task Manager and set up new task upon each login.

    When you do it properly, everything displays correctly. If you only apply it once and relog, system will automatically set DPIScalingVer back to the defaults.

    Here is the content of the file DPI_Fix.cmd file I used (set as Task upon each login):

    Code:
    REG ADD "HKCU\Control Panel\Desktop" /v DpiScalingVer /t REG_DWORD /d 0x00001018 /f
    REG ADD "HKCU\Control Panel\Desktop" /v Win8DpiScaling /t REG_DWORD /d 0x00000001 /f
    REG ADD "HKCU\Control Panel\Desktop" /v LogPixels /t REG_DWORD /d 0x00000078 /f
    
    again it is crucial to either drop it into Autostart or add as Task. I prefer the task option as it does not result with quick flash of the command window when logging in.
     

    Attached Files:

    • pt1.png
      pt1.png
      File size:
      24.2 KB
      Views:
      339
  9. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,378
    459
    120
    It should be possible in a system with higher resolution.
     
  10. Fra31

    Fra31 MDL Novice

    Jul 18, 2015
    3
    5
    0
    In accord to this table:

    DPI--->Scale Factor

    96--->100
    120--->125
    144--->150
    192--->200

    Every 25% of the scale factor corresponds to a difference of 24 dpi (120-96), so in theory if you set in registry key 72 you should have in Scale Factor 75%, may be it's possible.
     
  11. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,378
    459
    120
    This is what I got from the Scaling levels for even Windows 8.1 operating system.

    http://forums.mydigitallife.net/attachment.php?attachmentid=37344&stc=1
    View attachment 37344
     
  12. adric

    adric MDL Senior Member

    Jul 30, 2009
    465
    132
    10
    #12 adric, Jul 19, 2015
    Last edited: Jul 19, 2015
    I must admit, I did not run this from Autostart. I assumed the change would activate immediately which was a false assumption. Doing the change via Autostart seems to enable the change whereas if you do it later the change is not enabled. Event viewer etc. now have clear fonts. Sometimes I have to wonder about Ms. thanks for bringing back “Let me choose one scaling level for all my displays”
     
  13. woffko

    woffko MDL Novice

    Jan 23, 2008
    25
    4
    0
    I've asked Microsoft about this problem 2 months ago in Windows Feedback program, I've also asked for an option to give us scaling functionality back, like in win 8. "Feedback received", something fixed, something not and released to manufacturing :mad:. Good (blow)job, MS!
     
  14. AzTec

    AzTec MDL Member

    Aug 4, 2009
    117
    27
    10
    why not just use the scaling functionality thats already there under Control Panel/All control panel options/Display/set a custom scaling level
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. woffko

    woffko MDL Novice

    Jan 23, 2008
    25
    4
    0
    AzTec
    Just because it does not solve blurred fonts problem. It does not solve any problem at all. Before writing some "solution" you should try it on your own PC. Simple way to see the blurred font just open the Computer Management after scaling to 125%.
     
  16. emersonas

    emersonas MDL Novice

    Jan 3, 2011
    3
    0
    0
    #16 emersonas, Jul 25, 2015
    Last edited: Jul 25, 2015
    Autostart thingy from OP worked :worthy:
     
  17. woffko

    woffko MDL Novice

    Jan 23, 2008
    25
    4
    0
    I think that this problem was caused by using new "feature" code that should detect resolution and select best dpi level for all variable display range on the market.
    The main question is to be or not to be.... Would MS anyhow implement the fix into win10 or not?
     
  18. AzTec

    AzTec MDL Member

    Aug 4, 2009
    117
    27
    10
    #18 AzTec, Jul 25, 2015
    Last edited: Jul 25, 2015
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. WaltC

    WaltC MDL Addicted

    Mar 8, 2014
    518
    123
    30
    #19 WaltC, Jul 25, 2015
    Last edited: Jul 31, 2015
    Good points...I noticed the same a while back. My compromise was to enlarge all of the possible system fonts from 9 to 11 while leaving DPI @ 100%--but that is an imperfect solution at best because not all system fonts are affected. This is one thing I'll agree they handled better in 8.1--I always ran @ 125% DPI everywhere, and no text was blurry anywhere. I agree it's odd that they've missed that with 10 so far.

    Edit: Tried the workaround--works well. Cannot at all understand why Microsoft changed it...!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. woffko

    woffko MDL Novice

    Jan 23, 2008
    25
    4
    0

    It was only ONE sample of blurry font and it is embedded into windows 10, there are many other applications that have same problem.
    This bug is already in endless final version 10240, I don't think it will be fixed next month or whatever, just because people like you "can live with that". DAMN