Sound / Headset Problem with Win10

Discussion in 'Windows 10' started by Minu, Aug 5, 2015.

  1. Minu

    Minu MDL Novice

    Aug 5, 2015
    2
    0
    0
    Hello everyone,

    some of my friends and I have a weird sound problem with Windows 10. I have the Sennheiser Game One Headset and Asus Xonar U7 external audio card. When I used both on Win 7 I had absolutely no problem whatsoever.

    Then I upgraded to Win 10. The problem began, so I figured... ok lets clean install Win 10, maybe some drivers were corrupted during the upgrade. So I clean installed right away.

    The following problem is still occurring:

    The sound is total fine, but my microfone is making really loud scrape noises, when I talk louder than usual on Teamspeak 3. It is totally fine when i record my voice with e.g. Audacity. The Headset goes on mute, when I rotate the microfone to the top, when I do that my people on TS are getting heavily annoying loud scrapes and static noises, just like when I talk louder, kind of like my voice gets lost in static.

    Some friends who upgraded to Win 10 have the same problem with other headsets from other manufacturers, whereas other friends who upgraded have absolutely no problem.

    Do you think this is a problem with the drivers? Should I just wait for an update or is there any quick fix?

    Thank you in advance! :)
     
  2. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    453
    60
    Has microsoft loaded the drivers, or have you installed the newest drivers from the MFG ?.

    Are you running the Audio Driver 1.0.14 ?.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Minu

    Minu MDL Novice

    Aug 5, 2015
    2
    0
    0
    #3 Minu, Aug 5, 2015
    Last edited: Aug 5, 2015
    (OP)
    I am running Win 10 drivers, because the audio card is external (via USB) and Asus does not provide drivers for Win 10 at this moment (only Win 8.1).

    The driver version says: 10.0.10240.16384
    When I try to update it says it's already the newest driver.

    EDIT:

    I am just trying out Audio Driver 1.0.14 for Xonar U7 which says: Fix MIC problem. It's for Win 8, but maybe it works.

    EDIT 2:

    Okay, well this made it a bit better, but it's still a bit noisy when talking loud.