Stop UAC prompt for RDP users?

Discussion in 'Windows Server' started by kenw232, Apr 12, 2014.

  1. kenw232

    kenw232 MDL Novice

    Mar 2, 2014
    8
    0
    0
    For non-admin Remote Desktop Users in Windows Server 2012 R2 they get this dialog when they try to do something that is not allowed. Is there a way to stop this? I've disabled the policy "User Account Control: Run all administrators in Admin Approval Mode" but it does not help.

    uac.jpg
     
  2. replicant

    replicant MDL Junior Member

    Aug 20, 2007
    57
    18
    0
    you stated, that for non-admin users...
    so what do you expect from a "Run all administrators.." policy?

    you have to disable UAC for all (my guess)
     
  3. kenw232

    kenw232 MDL Novice

    Mar 2, 2014
    8
    0
    0
    I've tried the other more appropriate polices, they do nothing too. "Behavior of the elevation prompt for standard users" set to deny or whatever it is, it still shows the prompt.
     
  4. Myrrh

    Myrrh MDL Expert

    Nov 26, 2008
    1,431
    542
    60
    UAC is working as designed. The user tries to do something "not allowed" and it stops them.

    If you want them to be able to do a particular thing, look at the permissions related to doing the thing. For example, if they are getting the popup when trying to copy files to a folder, make the user a member of a group which has write permissions on that folder.

    If you want the users to have unlimited access to everything on the machine, make them members of the administrators group. I do not recommend this option.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...